diff --git a/testing/py3-json5/APKBUILD b/testing/py3-json5/APKBUILD
new file mode 100644
index 0000000000000000000000000000000000000000..115c80823c565def14def64d35d0183705073043
--- /dev/null
+++ b/testing/py3-json5/APKBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Alistair Francis <alistair@alistair23.me>
+pkgname=py3-json5
+_pyname=pyjson5
+pkgver=0.9.25
+pkgrel=0
+pkgdesc="A Python implementation of the JSON5 data format."
+url="https://github.com/dpranke/pyjson5"
+arch="noarch"
+license="Apache-2.0"
+depends="python3 py3-six"
+makedepends="
+	py3-gpep517
+	py3-installer
+	py3-wheel
+	py3-setuptools
+	"
+checkdepends="py3-pytest py3-setuptools py3-pexpect"
+source="py3-json5-$pkgver.tar.gz::https://github.com/dpranke/pyjson5/archive/refs/tags/v$pkgver.tar.gz"
+builddir="$srcdir"/$_pyname-$pkgver
+subpackages="$pkgname-pyc"
+
+build() {
+	gpep517 build-wheel \
+		--wheel-dir .dist \
+		--output-fd 3 3>&1 1>&2
+}
+
+check() {
+	python3 -m venv --clear --without-pip --system-site-packages .testenv
+	.testenv/bin/python3 -m installer .dist/*.whl
+	.testenv/bin/python3 -m pytest -k 'not test_python_render_simple_indent_guides and not test_python_render_line_range_indent_guides'
+}
+
+
+package() {
+	python3 -m installer -d "$pkgdir" .dist/*.whl
+}
+
+sha512sums="
+87c29da8589dbe853dd140cf61a90397feadffc75eb6ffb21c2c55951d9e00acb5ce3fd6ae6e1e266fb67de42e65489f1e3272f65015564a338fe607fdeeb832  py3-json5-0.9.25.tar.gz
+"