diff --git a/main/libxtst/APKBUILD b/main/libxtst/APKBUILD
index a4bb01030de5d82b51c674527b9ec06a24340cb0..d1608d1303d0121ed0bf1f90f28cbb521eb7c66f 100644
--- a/main/libxtst/APKBUILD
+++ b/main/libxtst/APKBUILD
@@ -1,7 +1,7 @@
 # Maintainer: Natanael Copa <ncopa@alpinelinux.org>
 pkgname=libxtst
-pkgver=1.2.3
-pkgrel=4
+pkgver=1.2.4
+pkgrel=0
 pkgdesc="X11 Testing -- Resource extension library"
 url="https://wiki.freedesktop.org/xorg/"
 arch="all"
@@ -9,15 +9,10 @@ license="custom"
 options="!check"  # No test suite.
 subpackages="$pkgname-dev $pkgname-doc"
 makedepends="xorgproto libx11-dev libxext-dev libxi-dev util-macros"
-source="https://www.x.org/releases/individual/lib/libXtst-$pkgver.tar.bz2
+source="https://www.x.org/releases/individual/lib/libXtst-$pkgver.tar.xz
 	"
 builddir="$srcdir"/libXtst-$pkgver
 
-prepare() {
-	default_prepare
-	update_config_sub
-}
-
 build() {
 	./configure \
 		--build=$CBUILD \
@@ -35,4 +30,6 @@ package() {
 	install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
 }
 
-sha512sums="6f6741fd3596775eaa056465319f78c29c91b3893a851a4899df651a2023a4d762497b112a33d7d3e8865fe85d173d03e4b49daef76a66af1ae1eaab82a12765  libXtst-1.2.3.tar.bz2"
+sha512sums="
+f2f4e01239b892b8e26284cede90feb4fe7738beb243bca0f6adb349029f8bf87b5a482911edcd2401733c92ef78eec07fcd455b92e5b8c4828374769e60098d  libXtst-1.2.4.tar.xz
+"