From b1681ce93dd216dc5e970af9cab57b0f8fe966b1 Mon Sep 17 00:00:00 2001
From: psykose <alice@ayaya.dev>
Date: Tue, 24 May 2022 06:02:05 +0000
Subject: [PATCH] community/glib-networking: revert back to gnutls

using openssl breaks geary:

GLib-GObject:invalid cast from 'ApplicationTlsDatabase' to 'GTlsDatabaseOpenssl'

this prevents any certificates from being trusted and hence connections
from working.

see #13847
---
 community/glib-networking/APKBUILD | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/community/glib-networking/APKBUILD b/community/glib-networking/APKBUILD
index c8f3d7ccb77c..90f5e81b84e4 100644
--- a/community/glib-networking/APKBUILD
+++ b/community/glib-networking/APKBUILD
@@ -3,13 +3,13 @@
 # Maintainer: Rasmus Thomsen <oss@cogitri.dev>
 pkgname=glib-networking
 pkgver=2.72.0
-pkgrel=1
+pkgrel=2
 pkgdesc="Networking support for GLib"
 url="https://gitlab.gnome.org/GNOME/glib-networking"
 arch="all"
 license="LGPL-2.0-or-later"
 depends="ca-certificates gsettings-desktop-schemas"
-makedepends="glib-dev openssl-dev libproxy-dev intltool libgcrypt-dev bash
+makedepends="glib-dev gnutls-dev libproxy-dev intltool libgcrypt-dev bash
 	p11-kit-dev meson gsettings-desktop-schemas-dev"
 subpackages="$pkgname-lang"
 options="!check" # connection-gnutls test fails
@@ -26,8 +26,8 @@ esac
 
 build() {
 	abuild-meson \
-		-Dopenssl=enabled \
-		-Dgnutls=disabled \
+		-Dopenssl=disabled \
+		-Dgnutls=enabled \
 		. build
 	meson compile ${JOBS:+-j ${JOBS}} -C build
 }
-- 
GitLab