diff --git a/testing/libdecor/APKBUILD b/testing/libdecor/APKBUILD
new file mode 100644
index 0000000000000000000000000000000000000000..294ced14f6f1a01a4c8189198eaf52f495210f04
--- /dev/null
+++ b/testing/libdecor/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Michał Polański <michal@polanski.me>
+# Maintainer: Michał Polański <michal@polanski.me>
+pkgname=libdecor
+pkgver=0.1.0
+pkgrel=0
+pkgdesc="Client-side decorations library for Wayland clients"
+url="https://gitlab.gnome.org/jadahl/libdecor"
+license="MIT"
+arch="all"
+makedepends="
+	meson
+	cairo-dev
+	dbus-dev
+	pango-dev
+	wayland-dev
+	wayland-protocols
+	"
+subpackages="$pkgname-dev"
+source="https://gitlab.gnome.org/jadahl/libdecor/-/archive/$pkgver/libdecor-$pkgver.tar.gz"
+options="!check" # no test suite
+
+build() {
+	abuild-meson \
+		-Ddemo=false \
+		. output
+	meson compile -C output
+}
+
+package() {
+	DESTDIR="$pkgdir" meson install --no-rebuild -C output
+}
+
+sha512sums="
+7e228b276efc98894085398ac8b4a37fb23a8ce3dfbb16c3d664d833f99e7d6365c43276880ef36d21d6471e1cdcae1925e6daaf95b4904b5701d103e023a916  libdecor-0.1.0.tar.gz
+"