diff --git a/community/dotnet6-build/APKBUILD b/community/dotnet6-build/APKBUILD
index f44b55c0da9afa5c61cc07eb5acf191a44c597e2..dfe1875f239d8ac6154ab3f6a496574072534a03 100644
--- a/community/dotnet6-build/APKBUILD
+++ b/community/dotnet6-build/APKBUILD
@@ -309,7 +309,10 @@ build() {
 	./build.sh \
 		--with-sdk "$_cli_root" \
 		--with-packages "$_artifactsdir" \
-		-- $args
+		-- $args || {
+		find . -name "CMakeConfigureLog.yaml" -type f -exec sh -c 'echo logfile: $1; cat $1' - {} \;
+		return 1
+	}
 }
 
 check() {