From af34062cf482f04e78fa33a92de25a5c27009c49 Mon Sep 17 00:00:00 2001
From: psykose <alice@ayaya.dev>
Date: Thu, 4 Aug 2022 11:59:48 +0000
Subject: [PATCH] main/pound: force usage of `openssl1.1`

---
 main/pound/APKBUILD             |  4 +++-
 main/pound/openssl1.1-cli.patch | 17 +++++++++++++++++
 2 files changed, 20 insertions(+), 1 deletion(-)
 create mode 100644 main/pound/openssl1.1-cli.patch

diff --git a/main/pound/APKBUILD b/main/pound/APKBUILD
index 587724402a44..32cdcf6774c1 100644
--- a/main/pound/APKBUILD
+++ b/main/pound/APKBUILD
@@ -6,10 +6,11 @@ pkgdesc="A reverse proxy, load balancer, and SSL wrapper"
 url="http://www.apsis.ch/pound/index_html"
 arch="all"
 license="GPL"
-makedepends="pcre-dev openssl1.1-compat-dev"
+makedepends="pcre-dev openssl1.1-compat openssl1.1-compat-dev"
 subpackages="$pkgname-doc"
 source="http://www.apsis.ch/$pkgname/Pound-$pkgver.tgz
 	openssl-1.1.patch
+	openssl1.1-cli.patch
 	pound.cfg
 	$pkgname.initd"
 
@@ -40,6 +41,7 @@ package() {
 sha512sums="
 cf0b865b17d3628e273626e07733f1320e4768702c0f64c8ef0f78d46667f770b223bdc7dca88016a95e5ebd23ae646f95a9b2f4a54a5a80001a10047f07eacc  Pound-2.8.tgz
 bc1ba9b6cca1e0cddc95ba519fb2ef11c8252e6585582d0ee26d083d360edc8e8baf52c2708c77895aa2c1453297180f80b9e2aa2a9f8c3c2cafd188447603b1  openssl-1.1.patch
+816c7bab8dd443d50bcc987f0ab291910b1543b68fdbfbfab80f021990e0f115687f0433b2770a4bbf8329219225cd34e77481832fecc6e8857b5952d55e18c5  openssl1.1-cli.patch
 9471e5abe3e0ee83165ed01a7081a4d14075c6c21b9f9d7c3fb239aa78c38eae74394a7c7e7e7753d218a7ce5cae388823570d19b702a829baa93e949a8946b8  pound.cfg
 cd014677ef7e724d5bd0a101436d0269d2fc18b4cd90ff71eaa690967754d3e4bfe5d0a439099967487b6256121ccc734b01880d96dff50d28242829715e7776  pound.initd
 "
diff --git a/main/pound/openssl1.1-cli.patch b/main/pound/openssl1.1-cli.patch
new file mode 100644
index 000000000000..8f797078ec72
--- /dev/null
+++ b/main/pound/openssl1.1-cli.patch
@@ -0,0 +1,17 @@
+diff --git a/Makefile.in b/Makefile.in
+index 82124cb..6ec0f7d 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -46,10 +46,10 @@ poundctl:	poundctl.o
+ 		${CC} @LDFLAGS@ -o poundctl poundctl.o $(LIBS)
+ 
+ dh512.h:
+-		openssl dhparam -5 -C -noout 512 > dh512.h
++		openssl1.1 dhparam -5 -C -noout 512 > dh512.h
+ 
+ dh@C_DH_LEN@.h:
+-		openssl dhparam -5 -C -noout @C_DH_LEN@ > dh@C_DH_LEN@.h
++		openssl1.1 dhparam -5 -C -noout @C_DH_LEN@ > dh@C_DH_LEN@.h
+ 
+ svc.o:		svc.c dh512.h dh@C_DH_LEN@.h
+ 		${CC} ${CFLAGS} -c -o svc.o svc.c
-- 
GitLab