diff --git a/testing/ocaml-sha/APKBUILD b/testing/ocaml-sha/APKBUILD
index 11030774cbc1df5de26a7f505dd2d3a4f0164409..979c1538b80a808b35c411a066c17fa51fa3820a 100644
--- a/testing/ocaml-sha/APKBUILD
+++ b/testing/ocaml-sha/APKBUILD
@@ -1,11 +1,11 @@
 # Contributor: Andy Li <andy@onthewings.net>
 # Maintainer: Andy Li <andy@onthewings.net>
 pkgname=ocaml-sha
-pkgver=1.12
+pkgver=1.14
 pkgrel=0
 pkgdesc="Binding to the SHA cryptographic functions"
 url="https://github.com/djs55/ocaml-sha"
-arch="all !x86 !armhf !armv7 !s390x !mips !mips64 !riscv64"  # limited by ocaml aport
+arch="all !mips !mips64 !riscv64"  # limited by ocaml aport
 license="ISC"
 depends="ocaml-runtime"
 depends_dev="$pkgname=$pkgver-r$pkgrel"
@@ -13,6 +13,11 @@ makedepends="dune ocaml ocaml-findlib ocaml-ounit-dev"
 subpackages="$pkgname-dev"
 source="$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
 
+# 32bit archs
+case "$CARCH" in
+    arm*|x86) options="$options textrels" ;;
+esac
+
 build() {
 	dune build @install -p sha --no-buffer --verbose
 }
@@ -46,4 +51,4 @@ dev() {
 		"$subpkgdir"/usr/lib/ocaml/sha/
 }
 
-sha512sums="e6cdbc66202281a72ccc3592d6efba0448fe28dba7a23f8079d3a3cee12c03d01338191da88e4e4834f5ee19321ffed1c950e7a5babc73479221d8da3fe372d3  ocaml-sha-1.12.tar.gz"
+sha512sums="8cc3f0b08c794cc335a09f5facc8c40126576ddf4646f4b6e25b76af912edd7677f94677bd7ea412b855e062b9ebf5780f673d497253936e538e6163cd03efec  ocaml-sha-1.14.tar.gz"