From ad72ed1e64e79af32c25df82073d2c65fcaaf05b Mon Sep 17 00:00:00 2001
From: Leo <thinkabit.ukim@gmail.com>
Date: Sat, 11 Apr 2020 16:39:26 -0300
Subject: [PATCH] community/pulseaudio: use python3 in the pulseaudio-equalizer
 shebang

fixes #11379
---
 community/pulseaudio/APKBUILD      |  4 +++-
 community/pulseaudio/python3.patch | 12 ++++++++++++
 2 files changed, 15 insertions(+), 1 deletion(-)
 create mode 100644 community/pulseaudio/python3.patch

diff --git a/community/pulseaudio/APKBUILD b/community/pulseaudio/APKBUILD
index 71a643628a8e..d6e8b3f6f37b 100644
--- a/community/pulseaudio/APKBUILD
+++ b/community/pulseaudio/APKBUILD
@@ -5,7 +5,7 @@
 # Maintainer: Leo <thinkabit.ukim@gmail.com>
 pkgname=pulseaudio
 pkgver=13.0
-pkgrel=6
+pkgrel=7
 pkgdesc="A featureful, general-purpose sound server"
 url="https://www.freedesktop.org/wiki/Software/PulseAudio/"
 arch="all"
@@ -61,6 +61,7 @@ subpackages="
 install="pulseaudio.post-install"
 source="https://freedesktop.org/software/pulseaudio/releases/pulseaudio-$pkgver.tar.xz
 	link-libintl.patch
+	python3.patch
 	$pkgname.initd
 	$pkgname.confd
 	"
@@ -234,5 +235,6 @@ equalizer() {
 
 sha512sums="d445b8ccd43029a0ca0e456fc9291a79d3434d6496ead7eb329ab348d5249235e8bde6cf2be68765d8f761452dbe1486fb10c739e40b1e67ed75787bbd24ac0c  pulseaudio-13.0.tar.xz
 126b66e8fd3e0b231beed987acf0f1aecb8a9da1c4d4591eb65a5d8d3e0561bd6b3652e2c3dc079350be4219df48a446a58c4539f7275edba941db846837baae  link-libintl.patch
+f45f4c9ddc75ff6a3ef42cc916bc11615b74fa1214502455d13a05c90acd3dcab652681bab1f768f7f02a863226a717bd63585c3405a9f58db40470b293d61d3  python3.patch
 34fe54ece5df60ce63a7955cd828a2716670fef71f40960698ae5518fdaf9cd599f4d8f8852e2c88d715600a9ad06a38984415e5eb320071012e5eb6e5c1b8b1  pulseaudio.initd
 75b54581591519d63a3362b155c0f9b0501a60763ab394693a456c44d0216138cf3a40bdd0f7442028663bc045e9ffee286f8f8eaf2ee3bb17379b43615fee0e  pulseaudio.confd"
diff --git a/community/pulseaudio/python3.patch b/community/pulseaudio/python3.patch
new file mode 100644
index 000000000000..1afe4306bc92
--- /dev/null
+++ b/community/pulseaudio/python3.patch
@@ -0,0 +1,12 @@
+Use python3 in the qt5 GUI for th pulseaudio equalizer
+
+diff --git a/src/utils/qpaeq b/src/utils/qpaeq
+index ac0daec..dd53a32 100755
+--- a/src/utils/qpaeq
++++ b/src/utils/qpaeq
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ #    qpaeq is a equalizer interface for pulseaudio's equalizer sinks
+ #    Copyright (C) 2009  Jason Newton <nevion@gmail.com
+ #
-- 
GitLab