From ad08fbd9aaf3a57d0e2502e24aac1d31651f4cf0 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?S=C3=B6ren=20Tempel?= <soeren+git@soeren-tempel.net>
Date: Thu, 19 Aug 2021 04:59:13 +0200
Subject: [PATCH] community/linux-edge: build CONFIG_IPV6_SIT as a module

This is the SIT configuration on all other architectures, having this as
a builtin will cause a `sit0` interfaces to be constantly available.
---
 community/linux-edge/APKBUILD                 | 6 +++---
 community/linux-edge/config-edge-virt.riscv64 | 6 +++---
 community/linux-edge/config-edge.riscv64      | 6 +++---
 3 files changed, 9 insertions(+), 9 deletions(-)

diff --git a/community/linux-edge/APKBUILD b/community/linux-edge/APKBUILD
index 11c2aa3cd609..bb4d5720eb00 100644
--- a/community/linux-edge/APKBUILD
+++ b/community/linux-edge/APKBUILD
@@ -9,7 +9,7 @@ case $pkgver in
 	*.*.*)	_kernver=${pkgver%.*};;
 	*.*) _kernver=$pkgver;;
 esac
-pkgrel=2
+pkgrel=3
 pkgdesc="Linux latest stable kernel"
 url="https://www.kernel.org"
 depends="mkinitfs"
@@ -227,9 +227,9 @@ a8edf97e9d38a49f1be2bde1e29ad96274bb2c6f7e8a2bebaa1161dd4df9cabcbaec4ff644c45bee
 3c79ed9f25883bee1f9b5f8f8d87fc6fa3a223b3fcd7e11ebbec9cb18b2562ac3d257bddbe00e9f069d5f3d893a3e814266e78d69afb2adad4e3ff80946acddb  config-edge.aarch64
 b59815fff833ec4894f9af02589dd3aa607eba96935116131742715a3ca88d9be8f68d469ee913d68785e6a49a7b4b8b9a1b14824c60e4d69ad0de9a275f0e16  config-edge.armv7
 c975dcaa3443fda63c03d835c74a0ad816cc065fe8c406627a2acbb9abdb0406fdb45461ff0761db8fa6bebf1f415327d7d3eea08eb70d95d9f2eed7e91ef0dc  config-edge.x86_64
-5ebe5b3330a5c944027c751bb8e15480fdf20ff061b0f4506c7d501fce2558ac007d05c562c7bcb2ee4054f1c1a26dcc1352ba01635ceba16acc707f316a6fe8  config-edge.riscv64
+e2bf21afd2367ffd0e0f2cc57153f6f68bc15aef2fbf83a2b129f879435e4e1f4f366067bcef9767ecbf0f5c24776887fb85425c8558b2762c1ce1383e6693d8  config-edge.riscv64
 cf25943457b196ec90a1b0860489197ea36030543b3ca784f1710fa306ee0c5876dbd3ed465655e365e6b80217b00dd6a5c41d5f8e7a6fcff38d75b3d7fb1b27  config-edge-virt.aarch64
 a57a7a19ac1ae47ea71d8e0a189a5f0cd38a19a5ee463004e721978d806449a81322565dbf169a91d1e1fdb42101a5f55b30c6e30a2b0547dd5ca314bf60c35f  config-edge-virt.armv7
 1f0d02f67e87ba0af3057dc961d920713ed9dd7ebc969e2bcb48cfa14392e3160066ed40b1796529d045b4ba899d9132ed7a40047480834c7e8ace0bd0d65e85  config-edge-virt.x86_64
-8ef4d1c76782cd60c42af8583952b66f8ae651a5b3c46d6db96bb0aeef52dc4d06ce47a28e9395adc302bc81bba595d1cdcd98e589080be4e56c26f5eee28fda  config-edge-virt.riscv64
+44481e1eab88c6f2c33f1f25a8d9233f13b4584bcd716a7717ae459ff808108649d642c98d5f4bca7fc850878d83b6f352e603d21e9da010c180ab9a3e307f8d  config-edge-virt.riscv64
 "
diff --git a/community/linux-edge/config-edge-virt.riscv64 b/community/linux-edge/config-edge-virt.riscv64
index 7df33d6a3f00..dc5acd069234 100644
--- a/community/linux-edge/config-edge-virt.riscv64
+++ b/community/linux-edge/config-edge-virt.riscv64
@@ -535,7 +535,7 @@ CONFIG_IP_PNP_BOOTP=y
 CONFIG_IP_PNP_RARP=y
 CONFIG_NET_IPIP=m
 # CONFIG_NET_IPGRE_DEMUX is not set
-CONFIG_NET_IP_TUNNEL=y
+CONFIG_NET_IP_TUNNEL=m
 # CONFIG_IP_MROUTE is not set
 CONFIG_SYN_COOKIES=y
 # CONFIG_NET_IPVTI is not set
@@ -545,7 +545,7 @@ CONFIG_NET_UDP_TUNNEL=m
 # CONFIG_INET_AH is not set
 # CONFIG_INET_ESP is not set
 # CONFIG_INET_IPCOMP is not set
-CONFIG_INET_TUNNEL=y
+CONFIG_INET_TUNNEL=m
 CONFIG_INET_DIAG=m
 CONFIG_INET_TCP_DIAG=m
 # CONFIG_INET_UDP_DIAG is not set
@@ -580,7 +580,7 @@ CONFIG_IPV6=y
 # CONFIG_INET6_IPCOMP is not set
 # CONFIG_IPV6_MIP6 is not set
 # CONFIG_IPV6_VTI is not set
-CONFIG_IPV6_SIT=y
+CONFIG_IPV6_SIT=m
 # CONFIG_IPV6_SIT_6RD is not set
 CONFIG_IPV6_NDISC_NODETYPE=y
 # CONFIG_IPV6_TUNNEL is not set
diff --git a/community/linux-edge/config-edge.riscv64 b/community/linux-edge/config-edge.riscv64
index 703f30184cd8..ec9d8a741073 100644
--- a/community/linux-edge/config-edge.riscv64
+++ b/community/linux-edge/config-edge.riscv64
@@ -537,7 +537,7 @@ CONFIG_IP_PNP_BOOTP=y
 CONFIG_IP_PNP_RARP=y
 CONFIG_NET_IPIP=m
 # CONFIG_NET_IPGRE_DEMUX is not set
-CONFIG_NET_IP_TUNNEL=y
+CONFIG_NET_IP_TUNNEL=m
 # CONFIG_IP_MROUTE is not set
 CONFIG_SYN_COOKIES=y
 # CONFIG_NET_IPVTI is not set
@@ -547,7 +547,7 @@ CONFIG_NET_UDP_TUNNEL=m
 # CONFIG_INET_AH is not set
 # CONFIG_INET_ESP is not set
 # CONFIG_INET_IPCOMP is not set
-CONFIG_INET_TUNNEL=y
+CONFIG_INET_TUNNEL=m
 CONFIG_INET_DIAG=y
 CONFIG_INET_TCP_DIAG=y
 # CONFIG_INET_UDP_DIAG is not set
@@ -582,7 +582,7 @@ CONFIG_IPV6=y
 # CONFIG_INET6_IPCOMP is not set
 # CONFIG_IPV6_MIP6 is not set
 # CONFIG_IPV6_VTI is not set
-CONFIG_IPV6_SIT=y
+CONFIG_IPV6_SIT=m
 # CONFIG_IPV6_SIT_6RD is not set
 CONFIG_IPV6_NDISC_NODETYPE=y
 # CONFIG_IPV6_TUNNEL is not set
-- 
GitLab