diff --git a/main/m4/APKBUILD b/main/m4/APKBUILD
index 3cd564ba92c607dfc142f10c8a70438e1bee3838..4b6e782f8a336ac92f013ac0ce2936f7f74bbc12 100644
--- a/main/m4/APKBUILD
+++ b/main/m4/APKBUILD
@@ -13,6 +13,7 @@ subpackages="m4-doc"
 source="https://ftp.gnu.org/gnu/m4/$pkgname-$pkgver.tar.gz
 	musl-realpath.patch
 	fix-sysval-test.patch
+	test-posix_spawn_file_actions_addclose.patch
 	"
 
 build() {
@@ -40,4 +41,5 @@ sha512sums="
 f5dd0f02fcae65a176a16af9a8e1747c26e9440c6c224003ba458d3298b777a75ffb189aee9051fb0c4840b2a48278be4a51d959381af0b1d627570f478c58f2  m4-1.4.19.tar.gz
 cc86f883eac255301615278af9ee172e13bbe48ce0ac318ab6c325ab2406000ceb10c5360868111210eb784ea028ef93cdfe12b77e17fa0066786957c347fd71  musl-realpath.patch
 d251842f8a6d71b4dc6912961bd873383b1b102a14ae3c1d06f44444b3db69d599fd8afec436734c4dad1c08de06c2ef2a48582a1528cc67b20f8db5afe287d9  fix-sysval-test.patch
+78f78f3f3145515da0a4b6f5fc891b0289b20d25f548d403f7de38f27a4b0f4bf06bf987d994ec85b61f4b28de1494a93c3347ff35b695becf8a5e9f2f3f7d49  test-posix_spawn_file_actions_addclose.patch
 "
diff --git a/main/m4/test-posix_spawn_file_actions_addclose.patch b/main/m4/test-posix_spawn_file_actions_addclose.patch
new file mode 100644
index 0000000000000000000000000000000000000000..079424a2436c481a9c728c10ecc6a6baeee803aa
--- /dev/null
+++ b/main/m4/test-posix_spawn_file_actions_addclose.patch
@@ -0,0 +1,18 @@
+diff --git a/tests/test-posix_spawn_file_actions_addclose.c b/tests/test-posix_spawn_file_actions_addclose.c
+index 2c910ea..b228a7d 100644
+--- a/tests/test-posix_spawn_file_actions_addclose.c
++++ b/tests/test-posix_spawn_file_actions_addclose.c
+@@ -54,13 +54,6 @@ main (void)
+     errno = 0;
+     ASSERT (posix_spawn_file_actions_addclose (&actions, -1) == EBADF);
+   }
+-  /* This behaviour is not mandated by POSIX, but happens to pass on all
+-     platforms.  */
+-  {
+-    int bad_fd = big_fd ();
+-    errno = 0;
+-    ASSERT (posix_spawn_file_actions_addclose (&actions, bad_fd) == EBADF);
+-  }
+ 
+   posix_spawn_file_actions_destroy (&actions);
+