From acb34b734c50d7ee47b2147e2d7b334b3c50cb22 Mon Sep 17 00:00:00 2001
From: psykose <alice@ayaya.dev>
Date: Thu, 8 Sep 2022 13:27:14 +0000
Subject: [PATCH] testing/hledger-timeclock: fix goflags

---
 testing/hledger-timeclock/APKBUILD | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/testing/hledger-timeclock/APKBUILD b/testing/hledger-timeclock/APKBUILD
index b3c62462469e..5ef929ca940a 100644
--- a/testing/hledger-timeclock/APKBUILD
+++ b/testing/hledger-timeclock/APKBUILD
@@ -13,14 +13,14 @@ subpackages="$pkgname-bash-completion
 	$pkgname-fish-completion"
 source="$pkgname-$pkgver.tar.gz::https://git.sr.ht/~dhruvin/hledger-timeclock/archive/v$pkgver.tar.gz"
 builddir="$srcdir/$pkgname-v$pkgver"
-options="!check"  # no tests
+options="!check chmod-clean"  # no tests
 
 export GOCACHE="$srcdir/go-cache"
 export GOTMPDIR="$srcdir"
 export GOMODCACHE="$srcdir/go"
 
 build() {
-	make all
+	make GOFLAGS="$GOFLAGS" all
 }
 
 package() {
-- 
GitLab