diff --git a/testing/hledger-timeclock/APKBUILD b/testing/hledger-timeclock/APKBUILD
index b3c62462469e053547411120bd98387b3d5a678b..5ef929ca940a4be323730e302eb1864b11994fd6 100644
--- a/testing/hledger-timeclock/APKBUILD
+++ b/testing/hledger-timeclock/APKBUILD
@@ -13,14 +13,14 @@ subpackages="$pkgname-bash-completion
 	$pkgname-fish-completion"
 source="$pkgname-$pkgver.tar.gz::https://git.sr.ht/~dhruvin/hledger-timeclock/archive/v$pkgver.tar.gz"
 builddir="$srcdir/$pkgname-v$pkgver"
-options="!check"  # no tests
+options="!check chmod-clean"  # no tests
 
 export GOCACHE="$srcdir/go-cache"
 export GOTMPDIR="$srcdir"
 export GOMODCACHE="$srcdir/go"
 
 build() {
-	make all
+	make GOFLAGS="$GOFLAGS" all
 }
 
 package() {