Commit ac3f3f3a authored by Roberto Oliveira's avatar Roberto Oliveira Committed by Natanael Copa

main/perl-test-script: upgrade to 1.23, modernize and add checkdepends

parent 627e091f
......@@ -3,7 +3,7 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=perl-test-script
_pkgreal=Test-Script
pkgver=1.18
pkgver=1.23
pkgrel=0
pkgdesc="Basic cross-platform tests for scripts"
url="http://search.cpan.org/dist/Test-Script/"
......@@ -12,6 +12,7 @@ license="GPL PerlArtistic"
cpandepends="perl-ipc-run3 perl-probe-perl perl-test-simple"
depends="$cpandepends"
makedepends="perl-dev $cpanmakedepends"
checkdepends="perl-test2-suite perl-capture-tiny"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/P/PL/PLICEASE/$_pkgreal-$pkgver.tar.gz"
......@@ -38,4 +39,4 @@ package() {
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
sha512sums="c89e1dd68ca275744ac12811f0d66d42f8fd76766cc515e11e0df2a82beb8cc052253e19b04f5bc86d45e3a9a2a1d6afd5cd4707e8a97f3a9d4c1dd28e4a72b4 Test-Script-1.18.tar.gz"
sha512sums="996564ba87b12849e86883b970117c9d5806be5b00d42207df1027f823a19497bf878640c46a8286e7d77afb8d1fbb3ef6dcfc0d21c2738a5ef124ddf5bc4834 Test-Script-1.23.tar.gz"
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment