diff --git a/testing/py3-pep8-naming/APKBUILD b/testing/py3-pep8-naming/APKBUILD
index 120d78796eb0d96a09239425d051dbcfa314ecaa..95d4dd82390f70cad7dca63fc848439fffbae925 100644
--- a/testing/py3-pep8-naming/APKBUILD
+++ b/testing/py3-pep8-naming/APKBUILD
@@ -1,8 +1,7 @@
 # Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
 # Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
 pkgname=py3-pep8-naming
-_pkgname=pep8-naming
-pkgver=0.9.1
+pkgver=0.10.0
 pkgrel=0
 pkgdesc="Check PEP-8 naming conventions plugin for flake8"
 url="https://github.com/flintwork/pep8-naming"
@@ -10,9 +9,13 @@ arch="noarch"
 license="MIT"
 depends="python3 py3-flake8"
 makedepends="py3-setuptools"
-checkdepends="py3-six py3-tox py3-virtualenv"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-builddir="$srcdir/$_pkgname-$pkgver"
+checkdepends="
+	py3-six
+	py3-tox
+	py3-virtualenv
+	"
+source="https://files.pythonhosted.org/packages/source/p/pep8-naming/pep8-naming-$pkgver.tar.gz"
+builddir="$srcdir/pep8-naming-$pkgver"
 
 replaces="py-pep8-naming" # Backwards compatibility
 provides="py-pep8-naming=$pkgver-r$pkgrel" # Backwards compatibility
@@ -29,4 +32,4 @@ package() {
 	python3 setup.py install --prefix=/usr --root="$pkgdir"
 }
 
-sha512sums="6a395d2fc2998f97b0592b2007323e21b97c20d4e2fbe4a541c9120f1c69efb4e10c3ce5f3e0c0305f48bfa42a7bf48668f881320ba1cf2fc808bf4447b63b82  pep8-naming-0.9.1.tar.gz"
+sha512sums="ee395e0ff4d3fce0153eb80784b9cb07b26e28ca1181a44b7776bee3302b16aa1ae3cbc320fc04c26a5330d20d9cc71019727600b213b796712b2ad40111a7e5  pep8-naming-0.10.0.tar.gz"