diff --git a/testing/baculum/APKBUILD b/testing/baculum/APKBUILD
index 740a0922da9df6bff061a06c89f2376ebb13b4df..00274958ad1acb75896ec850c1839578a71770ac 100644
--- a/testing/baculum/APKBUILD
+++ b/testing/baculum/APKBUILD
@@ -1,7 +1,7 @@
 # Maintainer: Natanael Copa <ncopa@alpinelinux.org>
 pkgname=baculum
-pkgver=9.6.3
-pkgrel=7
+pkgver=9.6.6
+pkgrel=0
 pkgdesc="API layer to Baculum WebGUI tool for Bacula Community program"
 url="https://bacula.org/"
 arch="noarch"
@@ -109,7 +109,6 @@ _api() {
 		"$subpkgdir"/usr/share/baculum/htdocs/protected/API/Config
 	ln --relative -s "$subpkgdir"/var/cache/baculum \
 		"$subpkgdir"/usr/share/baculum/htdocs/protected/API/Logs
-
 }
 
 _web() {
@@ -152,7 +151,7 @@ _web_lighttpd() {
 	amove etc/lighttpd/baculum-web.conf
 }
 
-sha512sums="1c23523cea4554eb4fbddfd5372567456c1a0df5752b063a5336e33ab1739ea288fb83355a698f54ee576bbe022aa12252e0a9d9942adbdd9c5bda627a16e339  bacula-gui-9.6.3.tar.gz
+sha512sums="c5971464ad9cebbbe2a213469418e81ca781f519ad5577e2ad0dcc607844254f03aaa83938934849a1a164e1f5d4b462d52e323a958d317a6839e295fc59446d  bacula-gui-9.6.6.tar.gz
 6c87cd9c4e2946077b9f0204cccf231b1e4f70620b18590511a84859b391acbc20ee8471c6d7b1c0e62b1b64ee2d77e39aee600b3ea474131cc39510e830155b  fix-missing-common-pages.patch
-c0b23e5383baa32494f80d044724a3990de4035c6124691bfbe3664bc11e4a6f7c35d1a08626c62816748b44497f33634dc9eb1c9ab661ade7647c0b6c0eac9d  fix-locale-symlinks.patch
-02dd4948d69f101d1b147b844e3bedb51bb6c34beaebdd2111d6f6c5c6d86c3dd6100152039a6bd8581ae9c8de870a408d7506e3cd7a7f1998c59c941fa85759  shared-config-dir.patch"
+88e2d8311a96f55a327b54a267dc1a694107d09f49640f6eb484e6e67ce9985750cfce20fa16755d2db82230d966001304fe033479d484f985af7aaa921a8915  fix-locale-symlinks.patch
+7b3f008e16151657aae57f4573b04f45fb2d791b90efce51ac74318f539240f73a4c8589d98f820b82bd11f5c4b3deeea052a3b33d7769357d63578096a1e0ae  shared-config-dir.patch"
diff --git a/testing/baculum/fix-locale-symlinks.patch b/testing/baculum/fix-locale-symlinks.patch
index dfc8d7c73102ea02dfadca8cce09e14af7458a40..b314fe37137e3129dda11693ec1c9eb5b099a40d 100644
--- a/testing/baculum/fix-locale-symlinks.patch
+++ b/testing/baculum/fix-locale-symlinks.patch
@@ -1,20 +1,20 @@
-diff --git a/baculum/Makefile b/baculum/Makefile
-index 224d35a..cf4729d 100644
+diff --git a/Makefile b/Makefile
+index b9cbbcb..74a3850 100644
 --- a/Makefile
 +++ b/Makefile
-@@ -118,13 +118,13 @@ prepare_locale: prepare_build
+@@ -122,13 +122,13 @@ prepare_locale: prepare_build
  		mkdir -p $(DESTDIR)$(LOCALEDIR)/$$lang/LC_MESSAGES ; \
  		mkdir -p $(DESTDIR)$(WWWDIR)/$(localewebdirsrc)/$$lang ; \
- 		install -m 644 $(localewebdirsrc)/$$lang/$(localefile) $(DESTDIR)$(LOCALEDIR)/$$lang/LC_MESSAGES/$(NAME)-web.mo ; \
--		ln -s $(DESTDIR)$(LOCALEDIR)/$$lang/LC_MESSAGES/$(NAME)-web.mo $(DESTDIR)$(WWWDIR)/$(localewebdirsrc)/$$lang/$(localefile) ; \
-+		ln --relative -s $(DESTDIR)$(LOCALEDIR)/$$lang/LC_MESSAGES/$(NAME)-web.mo $(DESTDIR)$(WWWDIR)/$(localewebdirsrc)/$$lang/$(localefile) ; \
+ 		install -m 644 $(localewebdirsrc)/$$lang/$(localemofile) $(DESTDIR)$(LOCALEDIR)/$$lang/LC_MESSAGES/$(NAME)-web.mo ; \
+-		ln -s $(DESTDIR)$(LOCALEDIR)/$$lang/LC_MESSAGES/$(NAME)-web.mo $(DESTDIR)$(WWWDIR)/$(localewebdirsrc)/$$lang/$(localemofile) ; \
++		ln --relative -s $(DESTDIR)$(LOCALEDIR)/$$lang/LC_MESSAGES/$(NAME)-web.mo $(DESTDIR)$(WWWDIR)/$(localewebdirsrc)/$$lang/$(localemofile) ; \
  	done
  	for lang in $(localeapilang) ; do \
  		mkdir -p $(DESTDIR)$(LOCALEDIR)/$$lang/LC_MESSAGES ; \
  		mkdir -p $(DESTDIR)$(WWWDIR)/$(localeapidirsrc)/$$lang ; \
- 		install -m 644 $(localeapidirsrc)/$$lang/$(localefile) $(DESTDIR)$(LOCALEDIR)/$$lang/LC_MESSAGES/$(NAME)-api.mo ; \
--		ln -s $(DESTDIR)$(LOCALEDIR)/$$lang/LC_MESSAGES/$(NAME)-api.mo $(DESTDIR)$(WWWDIR)/$(localeapidirsrc)/$$lang/$(localefile) ; \
-+		ln --relative -s $(DESTDIR)$(LOCALEDIR)/$$lang/LC_MESSAGES/$(NAME)-api.mo $(DESTDIR)$(WWWDIR)/$(localeapidirsrc)/$$lang/$(localefile) ; \
+ 		install -m 644 $(localeapidirsrc)/$$lang/$(localemofile) $(DESTDIR)$(LOCALEDIR)/$$lang/LC_MESSAGES/$(NAME)-api.mo ; \
+-		ln -s $(DESTDIR)$(LOCALEDIR)/$$lang/LC_MESSAGES/$(NAME)-api.mo $(DESTDIR)$(WWWDIR)/$(localeapidirsrc)/$$lang/$(localemofile) ; \
++		ln --relative -s $(DESTDIR)$(LOCALEDIR)/$$lang/LC_MESSAGES/$(NAME)-api.mo $(DESTDIR)$(WWWDIR)/$(localeapidirsrc)/$$lang/$(localemofile) ; \
  	done
  
  prepare_samples:
diff --git a/testing/baculum/shared-config-dir.patch b/testing/baculum/shared-config-dir.patch
index a3efb27489e9d7c1efce200d3de1f2260f302721..506f0e372beb856eab4fb89e1d588ee31c7681a3 100644
--- a/testing/baculum/shared-config-dir.patch
+++ b/testing/baculum/shared-config-dir.patch
@@ -1,5 +1,5 @@
 diff --git a/Makefile b/Makefile
-index b156cf7..b327ca9 100644
+index 74a3850..28792b6 100644
 --- a/Makefile
 +++ b/Makefile
 @@ -15,6 +15,7 @@ SYSCONFDIR = /etc
@@ -10,27 +10,25 @@ index b156cf7..b327ca9 100644
  UNITDIR = $(SYSUSRDIR)/lib/systemd/system
  LOCALEDIR = $(SYSUSRDIR)/share/locale
  WWWDIR ?= $(SYSUSRDIR)/share/$(NAME)/htdocs
-@@ -84,16 +85,15 @@ prepare_build:
+@@ -86,14 +87,13 @@ prepare_build:
  	mkdir -p $(DESTDIR)$(SYSCONFDIR) \
  	$(DESTDIR)$(CONFDIR) \
  	$(DESTDIR)$(HTTPDCONFDIR) \
 +	$(DESTDIR)$(LIGHTTPDCONFDIR) \
  	$(DESTDIR)$(UNITDIR) \
- 	$(DESTDIR)$(WWWDIR) \
- 	$(DESTDIR)$(CACHEDIR) \
  	$(DESTDIR)$(LOCALEDIR) \
- 	$(DESTDIR)$(WWWDIR)/$(cachedir) \
- 	$(DESTDIR)$(WWWDIR)/$(configcachedir)
+ 	$(DESTDIR)$(WWWDIR) \
+ 	$(DESTDIR)$(WWWDIR)/$(cachedir)
 -	mkdir -m 750 -p $(DESTDIR)$(CONFDIR)/$(configdir)-api-apache \
 -	$(DESTDIR)$(CONFDIR)/$(configdir)-api-lighttpd \
 -	$(DESTDIR)$(CONFDIR)/$(configdir)-web-apache \
--	$(DESTDIR)$(CONFDIR)/$(configdir)-web-lighttpd
+-	$(DESTDIR)$(CONFDIR)/$(configdir)-web-lighttpd \
 +	mkdir -m 750 -p $(DESTDIR)$(CONFDIR)/$(configdir)-api \
-+	$(DESTDIR)$(CONFDIR)/$(configdir)-web
- 
- prepare_data: prepare_build
- 	mkdir -p $(DESTDIR)$(WWWDIR)/$(datadir) \
-@@ -129,16 +129,14 @@ prepare_locale: prepare_build
++	$(DESTDIR)$(CONFDIR)/$(configdir)-web \
+ 	$(DESTDIR)$(WWWDIR)/$(configcachedir) \
+ 	$(DESTDIR)$(CACHEDIR) \
+ 	$(DESTDIR)$(VARLIBDIR)
+@@ -132,16 +132,14 @@ prepare_locale: prepare_build
  	done
  
  prepare_samples:
@@ -51,11 +49,7 @@ index b156cf7..b327ca9 100644
  	# Default link apache config file
  	#ln -s $(DESTDIR)$(CONFDIR)/$(configdir)-api-apache $(DESTDIR)$(WWWDIR)/$(datadir)/$(configdir)
  
-diff --git a/Makefile b/Makefile
-index 316e77f..136f29e 100644
---- a/Makefile
-+++ b/Makefile
-@@ -154,8 +154,8 @@ prepare_check_script:
+@@ -158,8 +156,8 @@ prepare_check_script:
  setup: prepare_samples prepare_check_script
  	sed -i -e "s#%DOCUMENTROOT#$(WWWDIR)#g" -e "s#%LOGDIR#$(HTTPDLOGS)#g" $(DESTDIR)$(HTTPDCONFDIR)/$(NAME)-api.conf
  	sed -i -e "s#%DOCUMENTROOT#$(WWWDIR)#g" -e "s#%LOGDIR#$(HTTPDLOGS)#g" $(DESTDIR)$(HTTPDCONFDIR)/$(NAME)-web.conf