diff --git a/community/filezilla/APKBUILD b/community/filezilla/APKBUILD
index 829a3e3b4583ad39a9c223c42da3eeb7d3d4598b..5bb260cf9b2d1e4c28406e0a6c2110cb2802db4f 100644
--- a/community/filezilla/APKBUILD
+++ b/community/filezilla/APKBUILD
@@ -1,6 +1,6 @@
 # Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
 pkgname=filezilla
-pkgver=3.47.1
+pkgver=3.48.0
 pkgrel=0
 pkgdesc="FTP Client"
 url="https://filezilla-project.org"
@@ -9,7 +9,12 @@ license="GPL-2.0-or-later"
 makedepends="gnutls-dev gtk+2.0-dev libfilezilla-dev>=0.18.0 libidn-dev
 	pugixml-dev sqlite-dev wxgtk3-dev xdg-utils"
 subpackages="$pkgname-doc $pkgname-lang"
-source="https://download.filezilla-project.org/client/FileZilla_${pkgver}_src.tar.bz2"
+source="https://download.filezilla-project.org/client/FileZilla_${pkgver}_src.tar.bz2
+	missing-list-include.patch"
+case "$CARCH" in
+	s390x)
+		options="!check" # ratelimit_test fails
+esac
 
 build() {
 	export CXXFLAGS="$CXXFLAGS -include assert.h"
@@ -33,4 +38,5 @@ package() {
 	make DESTDIR="$pkgdir" install
 }
 
-sha512sums="32573e847bc23acb86bdea8eb4de102e4f673465e0b86738d954b47eacdf6e534854a9065bddf8b586eba315bf65b1bfc4f17f9379819a6c9bd43ae6ed8f388a  FileZilla_3.47.1_src.tar.bz2"
+sha512sums="c9d4eb17dc31894468ca4b7c4c8fda0f307d3931bf1b3b8fb44afd084a1b2c9309d39e5745f9ba287a5566d44089af32350703e324a559afd6a015af469433fb  FileZilla_3.48.0_src.tar.bz2
+6280da4f1c359be7d49e8b590f036ddf1220ce6145fbba6c789c89d444a2a85d283275e402d996a6d28e9d5129f646b7920005d5d71faa4a80f0c734133c48a1  missing-list-include.patch"
diff --git a/community/filezilla/missing-list-include.patch b/community/filezilla/missing-list-include.patch
new file mode 100644
index 0000000000000000000000000000000000000000..29dd00e2075ad3622df642fda57658b5fea5a43b
--- /dev/null
+++ b/community/filezilla/missing-list-include.patch
@@ -0,0 +1,13 @@
+diff --git a/src/interface/Mainfrm.h b/src/interface/Mainfrm.h
+index 0641ff5..5da2840 100644
+--- a/src/interface/Mainfrm.h
++++ b/src/interface/Mainfrm.h
+@@ -8,6 +8,8 @@
+ 
+ #include <wx/timer.h>
+ 
++#include <list>
++
+ #ifndef __WXMAC__
+ #include <wx/taskbar.h>
+ #endif