diff --git a/testing/hare-vim/APKBUILD b/testing/hare-vim/APKBUILD
new file mode 100644
index 0000000000000000000000000000000000000000..ae97e5cefa0e83eaa21bc6cb814cd31193762d24
--- /dev/null
+++ b/testing/hare-vim/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=hare-vim
+_pkgname=hare.vim
+pkgver=0_git20220823
+_gitrev=0bdef854f8531747438f7764cf7553ba16e56fb8
+pkgrel=0
+pkgdesc="vim plugin for Hare language"
+url="https://git.sr.ht/~sircmpwn/hare.vim"
+arch="noarch"
+license="Vim"
+install_if="vim hare"
+source="$pkgname-$_gitrev.tar.gz::https://git.sr.ht/~sircmpwn/hare.vim/archive/$_gitrev.tar.gz"
+builddir="$srcdir/$_pkgname-$_gitrev"
+options="!check"  # no tests provided
+
+package() {
+	local destdir="$pkgdir/usr/share/vim/vimfiles"
+
+	mkdir -p "$destdir"
+	cp -r compiler ftdetect ftplugin indent syntax "$destdir"/
+}
+
+sha512sums="
+1cd0a1d536079f101cb6977916dfda59c2fefec6e03a8a04b70fdafbb0b1782bb6d26d82ea8dced999eaa9f425fb3407f4ba70538b2a5a4832da4f01aaca0326  hare-vim-0bdef854f8531747438f7764cf7553ba16e56fb8.tar.gz
+"