From a656db5189fd27eb29bd8455d26ab2a3173ec1cf Mon Sep 17 00:00:00 2001
From: psykose <alice@ayaya.dev>
Date: Sat, 10 Sep 2022 10:06:18 +0000
Subject: [PATCH] main/clang: depend on libstdc++-dev

---
 main/clang/APKBUILD | 6 ++----
 1 file changed, 2 insertions(+), 4 deletions(-)

diff --git a/main/clang/APKBUILD b/main/clang/APKBUILD
index 8451023f19f7..7a47b97a0266 100644
--- a/main/clang/APKBUILD
+++ b/main/clang/APKBUILD
@@ -6,7 +6,7 @@
 pkgname=clang
 # Note: Update together with llvm.
 pkgver=14.0.6
-pkgrel=3
+pkgrel=4
 _llvmver=${pkgver%%.*}
 pkgdesc="A C language family front-end for LLVM"
 arch="all"
@@ -77,9 +77,7 @@ check() {
 }
 
 package() {
-	# the libstdc++ headers are in g++, which are needed to use clang++.
-	# the better solution is to split libstdc++-dev, but that needs more testing
-	depends="g++"
+	depends="libstdc++-dev"
 	DESTDIR="$pkgdir" ninja -C build install
 	install -Dm644 build/lib/libclang.a -t "$pkgdir"/usr/lib/
 
-- 
GitLab