diff --git a/main/clang/APKBUILD b/main/clang/APKBUILD
index 8451023f19f763fef55086f4a24b1bf76d7d22ef..7a47b97a0266289aaa6ed48f69f74bfb3fcad320 100644
--- a/main/clang/APKBUILD
+++ b/main/clang/APKBUILD
@@ -6,7 +6,7 @@
 pkgname=clang
 # Note: Update together with llvm.
 pkgver=14.0.6
-pkgrel=3
+pkgrel=4
 _llvmver=${pkgver%%.*}
 pkgdesc="A C language family front-end for LLVM"
 arch="all"
@@ -77,9 +77,7 @@ check() {
 }
 
 package() {
-	# the libstdc++ headers are in g++, which are needed to use clang++.
-	# the better solution is to split libstdc++-dev, but that needs more testing
-	depends="g++"
+	depends="libstdc++-dev"
 	DESTDIR="$pkgdir" ninja -C build install
 	install -Dm644 build/lib/libclang.a -t "$pkgdir"/usr/lib/