Commit a64d0902 authored by Natanael Copa's avatar Natanael Copa

main/dahdi-linux-grsec: remove conflicting firmware

parent 269afbcf
......@@ -14,16 +14,16 @@ _realname=dahdi-linux
pkgname=${_realname}-${_flavor}
pkgver=2.2.0
pkgrel=7
pkgrel=8
pkgdesc="Digium Asterisk Hardware Device Interface drivers"
url="http://www.asterisk.org"
license="GPL"
#depends="dahdi-linux linux-${_flavor}=${_kernelver}"
depends="dahdi-linux linux-${_flavor}"
depends="dahdi-linux linux-${_flavor}=${_kernelver}"
# we need wget and tar because make install downloads firmware and uses fancy
# options for tar and wget.
#makedepends="linux-${_flavor}-dev=${_kernelver} wget tar perl"
makedepends="linux-${_flavor}-dev wget tar perl"
makedepends="linux-${_flavor}-dev=${_kernelver} wget tar perl"
#makedepends="linux-${_flavor}-dev wget tar perl"
install=
subpackages=
source="http://downloads.digium.com/pub/telephony/dahdi-linux/releases/${_realname}-$pkgver.tar.gz
......@@ -45,7 +45,7 @@ build() {
|| return 1
make KVERS="${_abi_release}" DYNFS="yes" MODULES_EXTRA="zaphfc" \
DESTDIR="$pkgdir" install
rm -r "$pkgdir"/lib/firmware
rm -rf "$pkgdir"/lib/firmware "$pkgdir"/usr/lib/hotplug/firmware
}
# since we sourced the APKBUILD above we got the dev() function there to
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment