diff --git a/community/rdfind/APKBUILD b/community/rdfind/APKBUILD
index cc8446b131e085cdcf0c9504a7b709e683fbf8de..33e3f22318bfbfcc77b09e56aec5efa11338e521 100644
--- a/community/rdfind/APKBUILD
+++ b/community/rdfind/APKBUILD
@@ -1,8 +1,8 @@
 # Contributor: Francesco Colista <fcolista@alpinelinux.org>
 # Maintainer: Francesco Colista <fcolista@alpinelinux.org>
 pkgname=rdfind
-pkgver=1.4.1
-pkgrel=2
+pkgver=1.5.0
+pkgrel=0
 pkgdesc="Redundant data find - a program that finds duplicate files"
 url="http://rdfind.pauldreik.se"
 arch="all"
@@ -10,30 +10,28 @@ license="GPL-2.0 "
 makedepends="nettle-dev automake autoconf libtool"
 subpackages="$pkgname-doc"
 source="https://rdfind.pauldreik.se/$pkgname-$pkgver.tar.gz
-disable-makefile-test-failing.patch"
+	disable-makefile-test-failing.patch"
 builddir="$srcdir/$pkgname-$pkgver"
 
 prepare() {
 	default_prepare
-	cd "$builddir"
 	./bootstrap.sh
 }
 
 build() {
-	cd "$builddir"
 	./configure	--prefix=/usr
 	make -s
 }
 
 check() {
-	cd "$builddir"
 	make check
 }
 
 package() {
-	cd "$builddir"
 	make DESTDIR="${pkgdir}/" install
 }
 
-sha512sums="38fceac92386b75cb66a85fb369dedc393e7ea08634f4972d83138c43c5ee04c3471df21aaf5192a8218714171fbc05cd7315c2422371d03c312d116c7902945  rdfind-1.4.1.tar.gz
-721274beca762433cd4ae15905d5ec13c8b4d21ca533dcf8b1f3e680a8c0c4043aa67ecedc7c863959dc9bb8b44cedd260486682d48aaa51a365982a4f3835ec  disable-makefile-test-failing.patch"
+sha512sums="
+0ba95e3d9ed4f127d271500c6f36c8945d0c8193fa2719636cc780e56de108e35404d1860edcb2fca2d9a4fb8b09dcd5dab904e55cf0530d664aaf8510be266b  rdfind-1.5.0.tar.gz
+ab53fabe698ed9fa31f31ed4828ce8f8b5582412a8ad97d2706aac3d1f6b21150ac8a73443e89c18a26b479b1cb4139e640d5c08c463cd01c7387dc311d10f1d  disable-makefile-test-failing.patch
+"
diff --git a/community/rdfind/disable-makefile-test-failing.patch b/community/rdfind/disable-makefile-test-failing.patch
index b709c911040023fdae521d2b1a07bb092387aa1d..50fcf3c9c8162a035d65901b2a3694cf29b51835 100644
--- a/community/rdfind/disable-makefile-test-failing.patch
+++ b/community/rdfind/disable-makefile-test-failing.patch
@@ -1,14 +1,37 @@
+diff --git a/Makefile.in b/Makefile.in
+index fc5907f..9c91865 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -497,16 +497,12 @@ rdfind_SOURCES = rdfind.cc Checksum.cc  Dirlist.cc  Fileinfo.cc  Rdutil.cc \
+ #these are the test scripts to execute - I do not know how to glob here,
+ #feedback welcome.
+ TESTS = testcases/largefilesupport.sh \
+-      testcases/hardlink_fails.sh \
+-      testcases/symlinking_action.sh \
+       testcases/verify_filesize_option.sh \
+       testcases/verify_maxfilesize_option.sh \
+-      testcases/verify_dryrun_option.sh \
+       testcases/verify_ranking.sh \
+       testcases/verify_deterministic_operation.sh \
+       testcases/checksum_options.sh \
+-      testcases/md5collisions.sh \
+-      testcases/sha1collisions.sh
++      testcases/md5collisions.sh 
+ 
+ AUXFILES = testcases/common_funcs.sh \
+          testcases/md5collisions/letter_of_rec.ps \
 diff --git a/Makefile.am b/Makefile.am
-index 7a28edc..15cc6d0 100644
+index 446eb39..aad38f7 100644
 --- a/Makefile.am
 +++ b/Makefile.am
-@@ -9,15 +9,11 @@ rdfind_SOURCES = rdfind.cc Checksum.cc  Dirlist.cc  Fileinfo.cc  Rdutil.cc \
+@@ -9,16 +9,12 @@ rdfind_SOURCES = rdfind.cc Checksum.cc  Dirlist.cc  Fileinfo.cc  Rdutil.cc \
  #these are the test scripts to execute - I do not know how to glob here,
  #feedback welcome.
  TESTS=testcases/largefilesupport.sh \
 -      testcases/hardlink_fails.sh \
 -      testcases/symlinking_action.sh \
        testcases/verify_filesize_option.sh \
+       testcases/verify_maxfilesize_option.sh \
 -      testcases/verify_dryrun_option.sh \
        testcases/verify_ranking.sh \
        testcases/verify_deterministic_operation.sh \
@@ -19,25 +42,3 @@ index 7a28edc..15cc6d0 100644
  
  AUXFILES=testcases/common_funcs.sh \
           testcases/md5collisions/letter_of_rec.ps \
--
--
--
--
--
--
- set_more_warnings=no
- # Check whether --enable-warnings was given.
- if test "${enable_warnings+set}" = set; then :
-diff --git a/configure.ac b/configure.ac
-index c494cb4..e1f8d85 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -70,8 +70,6 @@ AC_ARG_ENABLE(cppstandardcheck,
- 	[ ENABLECPPSTANDARDCHECK=yes] )
- if test "$ENABLECPPSTANDARDCHECK" = "yes"; then
-    AC_MSG_NOTICE([checking for c++ 11, disable with --disable-cppstandardcheck])
--   dnl AX_CXX_COMPILE_STDCXX_11([noext], [mandatory])
--   AX_CXX_COMPILE_STDCXX([11],[noext],[mandatory])
- else
-    AC_MSG_NOTICE([not checking for c++11 support.])
- fi