diff --git a/community/py3-typing-extensions/APKBUILD b/community/py3-typing-extensions/APKBUILD
index c3534520058702ce9ba9314ea54834b702f00c45..50c5f3bb63f539c79ee703f00e7ad22016441a5e 100644
--- a/community/py3-typing-extensions/APKBUILD
+++ b/community/py3-typing-extensions/APKBUILD
@@ -1,17 +1,17 @@
 # Contributor: Leo <thinkabit.ukim@gmail.com>
 # Maintainer: psykose <alice@ayaya.dev>
 pkgname=py3-typing-extensions
-pkgver=4.2.0
+pkgver=4.3.0
 pkgrel=0
 pkgdesc="Backported and Experimental Type Hints for Python 3.5+"
-url="https://github.com/python/typing/blob/master/typing_extensions/README.rst"
+url="https://github.com/python/typing_extensions"
 arch="noarch"
 license="Python-2.0"
 depends="python3"
 makedepends="py3-build py3-flit-core py3-installer py3-wheel"
 checkdepends="py3-tox python3-tests"
-source="https://github.com/python/typing/archive/$pkgver/typing-$pkgver.tar.gz"
-builddir="$srcdir/typing-$pkgver/typing_extensions"
+source="https://github.com/python/typing_extensions/archive/$pkgver/typing_extensions-$pkgver.tar.gz"
+builddir="$srcdir/typing_extensions-$pkgver"
 
 build() {
 	python3 -m build --no-isolation --wheel
@@ -27,5 +27,5 @@ package() {
 }
 
 sha512sums="
-52e67eaeb3159e5effdcf180fc43d9881453c7efc00546335a8f31d5f7ab9859c2f89b29612861015ba490cdfd596720aa577630b424323256930b036b119776  typing-4.2.0.tar.gz
+3c4a9073dc89e71b8027d535853d35725163961f7feeaba817e28f93b236bcae805d9b1f6e2be8e9fc3651c283b662935ba0352e5de25ff74df4dc18373e8f7a  typing_extensions-4.3.0.tar.gz
 "