From a48c0c6157edb31781f2d86b05e3938d3a909fa5 Mon Sep 17 00:00:00 2001
From: mio <miyopan@e.email>
Date: Thu, 14 Nov 2024 22:09:52 +0000
Subject: [PATCH] community/mustach: disable valgrind in tests on s390x

Running the tests with valgrind resulted in a segfault on the 3.21 s390x
builder. Disable use of valgrind in tests on the arch until resolved.

```
==8545== Memcheck, a memory error detector
==8545== Copyright (C) 2002-2024, and GNU GPL'd, by Julian Seward et al.
==8545== Using Valgrind-3.23.0 and LibVEX; rerun with -h for copyright info
==8545== Command: ../mustach json must
==8545==

valgrind: m_debuginfo/image.c:700 (get_slowcase): Assertion 'i <= img->ces_used' failed.
Segmentation fault
```
---
 community/mustach/APKBUILD | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/community/mustach/APKBUILD b/community/mustach/APKBUILD
index a3eeed65fa54..0e4aa1d9e8a8 100644
--- a/community/mustach/APKBUILD
+++ b/community/mustach/APKBUILD
@@ -20,9 +20,10 @@ for _j in $_jsonlibs; do
 done
 
 # armv7: Segmentation fault (valgrind error #15759)
+# s390x: Segmentation fault (valgrind error on 3.21 builder)
 # armhf,riscv64,loongarch64: doesn't have valgrind
 case "$CARCH" in
-armv7|armhf|riscv64|loongarch64) export NOVALGRIND=1;;
+armv7|s390x|armhf|riscv64|loongarch64) export NOVALGRIND=1;;
 *) checkdepends="valgrind";;
 esac
 
-- 
GitLab