diff --git a/community/mustach/APKBUILD b/community/mustach/APKBUILD
index a3eeed65fa5460b04a3ff9e20ee6c272fb3e353d..0e4aa1d9e8a862b4146b6c97051e76f7275453f5 100644
--- a/community/mustach/APKBUILD
+++ b/community/mustach/APKBUILD
@@ -20,9 +20,10 @@ for _j in $_jsonlibs; do
 done
 
 # armv7: Segmentation fault (valgrind error #15759)
+# s390x: Segmentation fault (valgrind error on 3.21 builder)
 # armhf,riscv64,loongarch64: doesn't have valgrind
 case "$CARCH" in
-armv7|armhf|riscv64|loongarch64) export NOVALGRIND=1;;
+armv7|s390x|armhf|riscv64|loongarch64) export NOVALGRIND=1;;
 *) checkdepends="valgrind";;
 esac