diff --git a/community/nushell/APKBUILD b/community/nushell/APKBUILD
index b632179b116fdfa92378ad1303cf1d1a959b86cf..c61c6e3b346e358e0cb9a815f043ca7690a601fc 100644
--- a/community/nushell/APKBUILD
+++ b/community/nushell/APKBUILD
@@ -1,7 +1,7 @@
 # Contributor: nibon7 <nibon7@163.com>
 # Maintainer: nibon7 <nibon7@163.com>
 pkgname=nushell
-pkgver=0.95.0
+pkgver=0.96.0
 pkgrel=0
 pkgdesc="A new type of shell"
 url="https://www.nushell.sh"
@@ -23,7 +23,6 @@ subpackages="$pkgname-doc $pkgname-plugins:_plugins"
 install="$pkgname.post-install $pkgname.post-upgrade $pkgname.pre-deinstall"
 source="$pkgname-$pkgver.tar.gz::https://github.com/nushell/nushell/archive/$pkgver.tar.gz
 	system-deps.patch
-	cargo-update.patch
 	"
 
 export LIBSSH2_SYS_USE_PKG_CONFIG=1  # use system libssh2
@@ -89,7 +88,6 @@ _plugins() {
 }
 
 sha512sums="
-cb13a647858a4ccd9dac3b93f509c9f6f8138e7b6f46a3b2abe5df656a931215a5d42bf39904693e9b31cf502e15a86ca59df9e4af0ca5391773fda6385c7c46  nushell-0.95.0.tar.gz
-3ebe0d34ef0c88c2cc9486827711feea5ce102d8e02bcbc009e62e05c0c4ba51674d6e18711e337fb36cef707c8a65df9a5e0cf8f7bef780070b328e14f7cac6  system-deps.patch
-35b1c3f2ef2d3a4feaf7e2a4f0984fdfd5543ceecfbfddcc945c3e5dd8f59f4b2be333ec5d0a3c236368d4ccd02597dfbc40e088024483590bd4c97513fef009  cargo-update.patch
+29103258829818fb8a666674f3c9cb3b393732f1bebbf2275bb8095c30e3cc090a448855cd8b254bf6a9f2d499546b51d71a6fedd57b79dcad2284ee88a19c59  nushell-0.96.0.tar.gz
+285208a9aa11937a28cd7233f58b87cb140e5ebc1cfa09df6ebd92e296b087c3c8ebd69356c191e92145ff92e9f6c93aaa783e7caf5f4120189ca7b096e5badd  system-deps.patch
 "
diff --git a/community/nushell/cargo-update.patch b/community/nushell/cargo-update.patch
deleted file mode 100644
index 33ee8fdfd5737bd0abc580a62e50584b3aefa077..0000000000000000000000000000000000000000
--- a/community/nushell/cargo-update.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-diff --git a/Cargo.lock b/Cargo.lock
-index a344560..a1a61ca 100644
---- a/Cargo.lock
-+++ b/Cargo.lock
-@@ -2170,9 +2170,9 @@ dependencies = [
- 
- [[package]]
- name = "libc"
--version = "0.2.154"
-+version = "0.2.155"
- source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "ae743338b92ff9146ce83992f766a31066a91a8c84a45e0e9f21e7cf6de6d346"
-+checksum = "97b3888a4aecf77e811145cadf6eef5901f4782c53886191b2f693f24761847c"
- 
- [[package]]
- name = "libflate"
diff --git a/community/nushell/system-deps.patch b/community/nushell/system-deps.patch
index 00b04c2b9e8b7f0d1e5117f9d87ed9d8399a2cfc..b8f0812a06c18458ca21fd7a07489378ae053bb9 100644
--- a/community/nushell/system-deps.patch
+++ b/community/nushell/system-deps.patch
@@ -1,6 +1,6 @@
 --- a/Cargo.lock
 +++ b/Cargo.lock
-@@ -2262,7 +2262,6 @@
+@@ -2433,7 +2433,6 @@
  source = "registry+https://github.com/rust-lang/crates.io-index"
  checksum = "0c10584274047cb335c23d3e61bcef8e323adae7c5c8c760540f73610177fc3f"
  dependencies = [
@@ -10,10 +10,10 @@
  ]
 --- a/Cargo.toml
 +++ b/Cargo.toml
-@@ -181,7 +181,7 @@
- nu-system = { path = "./crates/nu-system", version = "0.95.0" }
- nu-utils = { path = "./crates/nu-utils", version = "0.95.0" }
- 
+@@ -199,7 +199,7 @@
+ nu-std = { path = "./crates/nu-std", version = "0.96.0" }
+ nu-system = { path = "./crates/nu-system", version = "0.96.0" }
+ nu-utils = { path = "./crates/nu-utils", version = "0.96.0" }
 -reedline = { workspace = true, features = ["bashisms", "sqlite"] }
 +reedline = { workspace = true, features = ["bashisms", "sqlite-dynlib"] }
  
@@ -21,9 +21,9 @@
  ctrlc = { workspace = true }
 --- a/crates/nu-cli/Cargo.toml
 +++ b/crates/nu-cli/Cargo.toml
-@@ -25,7 +25,7 @@
- nu-utils = { path = "../nu-utils", version = "0.95.0" }
- nu-color-config = { path = "../nu-color-config", version = "0.95.0" }
+@@ -27,7 +27,7 @@
+ nu-utils = { path = "../nu-utils", version = "0.96.0" }
+ nu-color-config = { path = "../nu-color-config", version = "0.96.0" }
  nu-ansi-term = { workspace = true }
 -reedline = { workspace = true, features = ["bashisms", "sqlite"] }
 +reedline = { workspace = true, features = ["bashisms", "sqlite-dynlib"] }
@@ -32,7 +32,7 @@
  crossterm = { workspace = true }
 --- a/crates/nu-command/Cargo.toml
 +++ b/crates/nu-command/Cargo.toml
-@@ -72,7 +72,7 @@
+@@ -75,7 +75,7 @@
  rayon = { workspace = true }
  regex = { workspace = true }
  roxmltree = { workspace = true }