diff --git a/testing/fast_float/APKBUILD b/testing/fast_float/APKBUILD
index c8490e840d3074cb1b6b160dd236f5f311674b43..3655e7fc6ea07d22b3860e11177460e033d5519e 100644
--- a/testing/fast_float/APKBUILD
+++ b/testing/fast_float/APKBUILD
@@ -3,20 +3,32 @@
 pkgname=fast_float
 pkgver=3.4.0
 pkgrel=0
+_tests=97a0b2e638feb479387554cf253e346500541e7e
 pkgdesc="Fast implementation of the C++ from_chars functions for float and double types"
 url="https://github.com/fastfloat/fast_float"
 arch="noarch"
 license="Apache-2.0 OR MIT"
 makedepends="cmake samurai"
 checkdepends="doctest-dev"
-source="https://github.com/fastfloat/fast_float/archive/v$pkgver/fast_float-$pkgver.tar.gz"
+source="https://github.com/fastfloat/fast_float/archive/v$pkgver/fast_float-$pkgver.tar.gz
+	https://github.com/fastfloat/supplemental_test_files/archive/$_tests.tar.gz
+	"
+
+prepare() {
+	default_prepare
+
+	mkdir -p builddir/_deps
+	mv "$srcdir"/supplemental_test_files-$_tests \
+		builddir/_deps/supplemental_test_files-src
+}
 
 build() {
 	cmake -B builddir -G Ninja \
 		-DCMAKE_INSTALL_PREFIX=/usr \
 		-DCMAKE_BUILD_TYPE=Release \
 		-DFASTFLOAT_TEST="$(want_check && echo ON || echo OFF)" \
-		-DSYSTEM_DOCTEST=ON
+		-DSYSTEM_DOCTEST=ON \
+		-DFETCHCONTENT_FULLY_DISCONNECTED=ON
 	cmake --build builddir
 }
 
@@ -32,4 +44,5 @@ package() {
 
 sha512sums="
 6adf278eca5be16c1fbf9ba04edba71fff4af92fca37ca5f3ea8fcd5f31497b7f8f4654c500a4ef6e521053b4125409d34f484a2dd5b45399b49be9c143270a1  fast_float-3.4.0.tar.gz
+f2714a5d406c4e1f7a6e180a95d795edaa9033e6988955b76143884c020a9c379754474aa92f739a7f1feb9ac2d6c8d3bdb4ebe8bd23ab4b352ab809821eb43a  97a0b2e638feb479387554cf253e346500541e7e.tar.gz
 "