Commit a060ffa4 authored by Natanael Copa's avatar Natanael Copa

main/lua-subprocess: use install_if

parent fa7eabbb
......@@ -4,7 +4,7 @@
_luaversions="5.1 5.2"
pkgname=lua-subprocess
pkgver=0.0.20141229
pkgrel=1
pkgrel=2
pkgdesc="A Lua module written in C that allows you to create child processes and communicate with them"
url="https://github.com/tdtrask/lua-subprocess"
arch="all"
......@@ -15,7 +15,6 @@ depends_dev=""
makedepends="$depends_dev asciidoc"
subpackages=""
for _i in $_luaversions; do
depends="$depends lua$_i-subprocess"
makedepends="$makedepends lua$_i-dev"
subpackages="$subpackages lua$_i-subprocess:split_${_i/./_}"
done
......@@ -77,6 +76,7 @@ package() {
_split() {
local d= _ver=$1
pkgdesc="A Lua $_ver module written in C that allows you to create child processes and communicate with them"
install_if="lua$_ver $pkgname=$pkgver-r$pkgrel"
replaces="$pkgname"
depends=
for d in usr/lib/lua usr/share/lua; do
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment