From a01dd3dfbc7d0fb77cb35b0c0b94832ec65252d7 Mon Sep 17 00:00:00 2001
From: mio <miyopan@e.email>
Date: Wed, 11 Sep 2024 01:18:00 +0000
Subject: [PATCH] community/opencascade: fix build

---
 community/opencascade/APKBUILD                |  4 ++-
 .../freetype-use-unsigned-point.patch         | 27 +++++++++++++++++++
 2 files changed, 30 insertions(+), 1 deletion(-)
 create mode 100644 community/opencascade/freetype-use-unsigned-point.patch

diff --git a/community/opencascade/APKBUILD b/community/opencascade/APKBUILD
index e0363a7f3793..68fa6ca3a4ea 100644
--- a/community/opencascade/APKBUILD
+++ b/community/opencascade/APKBUILD
@@ -2,7 +2,7 @@
 # Contributor: Marian Buschsieweke <marian.buschsieweke@posteo.net>
 pkgname=opencascade
 pkgver=7.8.1
-pkgrel=2
+pkgrel=3
 pkgdesc="SDK for development of applications dealing with 3D CAD data"
 url="https://dev.opencascade.org/"
 # s390x blocked by vtk -> netcdf
@@ -30,6 +30,7 @@ source="$pkgname-$pkgver-updatecache.tar.gz::https://github.com/Open-Cascade-SAS
 	no_backtrace.patch
 	x11vtkconflict.patch
 	drop-nonsense-from-cmake.patch
+	freetype-use-unsigned-point.patch
 	"
 builddir="$srcdir/OCCT-${pkgver//./_}"
 options="!check" # No tests provided :-/
@@ -68,4 +69,5 @@ b039b8fce696bfd0f53309a72adab4065780bf1755da6208040157e9383deb0061ad8927a6f16073
 86dceb6e8309e18f5ea72ce2e3524ff08dc761ffe76557d62a1a4f2824ca0e2f9dfc194cae22164aaaf5ad9a15a6ec0f1fef443241aa2ccb0a2140de217c8a90  no_backtrace.patch
 8f5abf58f4a1b84aee99c75bbaeb2267655f306b6a3e12600a4db34201106dd380c7e30e37d4db81841be8ba9455604a10bfaa6e50e73801097ce141840f3d8e  x11vtkconflict.patch
 ed289ac71cf8426609038361122a54e76f8c7a78989555be619c2ee44233a32bfd386cfee345d701e6a986e7a3df29e7d36dc14cd7a9f11d055350938e29c619  drop-nonsense-from-cmake.patch
+8667ff2a31f6d704c3e1979d51bc0538ab60cfab1efc6ced1f1509dd284c866d5b7529a4fb8fad6db734fe3ec5c3120a299e198b1dbae260e07d67a4bdc5b5ff  freetype-use-unsigned-point.patch
 "
diff --git a/community/opencascade/freetype-use-unsigned-point.patch b/community/opencascade/freetype-use-unsigned-point.patch
new file mode 100644
index 000000000000..b84ce07faff6
--- /dev/null
+++ b/community/opencascade/freetype-use-unsigned-point.patch
@@ -0,0 +1,27 @@
+Source: https://github.com/Open-Cascade-SAS/OCCT/commit/7236e83dcc1e7284e66dc61e612154617ef715d6
+Info: https://github.com/Open-Cascade-SAS/OCCT/discussions/48
+---
+From 7236e83dcc1e7284e66dc61e612154617ef715d6 Mon Sep 17 00:00:00 2001
+From: dpasukhi <dpasukhi@opencascade.com>
+Date: Tue, 27 Aug 2024 11:33:29 +0100
+Subject: [PATCH] 0033808: Coding - FreeType Use unsigned point and contour
+ indexing in `FT_Outline`
+
+Changes to auto instead of specific type
+---
+ src/StdPrs/StdPrs_BRepFont.cxx | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/StdPrs/StdPrs_BRepFont.cxx b/src/StdPrs/StdPrs_BRepFont.cxx
+index ab2d9b3c9f..cd701879b1 100644
+--- a/src/StdPrs/StdPrs_BRepFont.cxx
++++ b/src/StdPrs/StdPrs_BRepFont.cxx
+@@ -457,7 +457,7 @@ Standard_Boolean StdPrs_BRepFont::renderGlyph (const Standard_Utf32Char theChar,
+   for (short aContour = 0, aStartIndex = 0; aContour < anOutline->n_contours; ++aContour)
+   {
+     const FT_Vector* aPntList = &anOutline->points[aStartIndex];
+-    const char* aTags      = &anOutline->tags[aStartIndex];
++    const auto* aTags      = &anOutline->tags[aStartIndex];
+     const short anEndIndex = anOutline->contours[aContour];
+     const short aPntsNb    = (anEndIndex - aStartIndex) + 1;
+     aStartIndex = anEndIndex + 1;
-- 
GitLab