diff --git a/testing/spiped/APKBUILD b/testing/spiped/APKBUILD
new file mode 100644
index 0000000000000000000000000000000000000000..6f581588dc435a807d8d42c515d07a80fc32a454
--- /dev/null
+++ b/testing/spiped/APKBUILD
@@ -0,0 +1,23 @@
+# Contributor: Elly <elly@elly.town>
+# Maintainer: Elly <elly@elly.town>
+pkgname=spiped
+pkgver=1.6.2
+pkgrel=0
+pkgdesc="Encrypted network pipe utility"
+url="https://www.tarsnap.com/spiped.html"
+arch="all"
+license="BSD-2-Clause"
+makedepends="openssl-dev"
+source="https://www.tarsnap.com/spiped/spiped-$pkgver.tgz"
+
+check() {
+	make test
+}
+
+package() {
+	make BINDIR="$pkgdir/bin" install
+}
+
+sha512sums="
+d16262a3e8be876ca1ef1aac8bb38fae91f523a9af0d488eb0dfa23e0b9db795d2a021e55f31095d92f5b94e4516e30ea23f537c3b14a2f1b9871297e26cda76  spiped-1.6.2.tgz
+"