diff --git a/community/libslirp/APKBUILD b/community/libslirp/APKBUILD
index 8ecca2771c16481dc060e7ecf94f29d6b46746e8..20d53e36fc98f06a142067d21347ea91a3e1d3dc 100644
--- a/community/libslirp/APKBUILD
+++ b/community/libslirp/APKBUILD
@@ -1,7 +1,7 @@
 # Contributor: Michał Polański <michal@polanski.me>
 # Maintainer: Michał Polański <michal@polanski.me>
 pkgname=libslirp
-pkgver=4.3.1
+pkgver=4.4.0
 pkgrel=0
 pkgdesc="A general purpose TCP-IP emulator"
 url="https://gitlab.freedesktop.org/slirp/libslirp"
@@ -10,21 +10,18 @@ license="BSD-3-Clause"
 makedepends="meson glib-dev"
 subpackages="$pkgname-dev"
 options="!check" # no test suite
-source="https://gitlab.freedesktop.org/slirp/libslirp/-/archive/v$pkgver/libslirp-v$pkgver.tar.gz
-	version.patch"
+source="https://gitlab.freedesktop.org/slirp/libslirp/-/archive/v$pkgver/libslirp-v$pkgver.tar.gz"
 builddir="$srcdir/$pkgname-v$pkgver"
 
 # secfixes:
+#   4.4.0-r0:
+#     - CVE-2020-29129
+#     - CVE-2020-29130
 #   4.3.1-r0:
 #     - CVE-2020-10756
 #   4.3.0-r0:
 #     - CVE-2020-1983
 
-prepare() {
-	default_prepare
-	sed -i "s/%SLIRP_VERSION%/$pkgver/g" meson.build
-}
-
 build() {
 	abuild-meson build
 	meson compile ${JOBS:+-j ${JOBS}} -C build
@@ -34,5 +31,4 @@ package() {
 	DESTDIR="$pkgdir" meson install --no-rebuild -C build
 }
 
-sha512sums="fa38a5e508b00802538f8466b8b52fc4842d6f7f74caa399db1011c15bb37198678415147327a606e3f259fd5def9390012df1d4dc76e8869e9bb77ca6514005  libslirp-v4.3.1.tar.gz
-adb828ebbaeecbba313c028b34deb96ad592f53fb2f777d58286bf8397285be8714ae4cdbaad086168cc0ac7c729a2fc34e6e57f82c7d657c29884e3f3fa59aa  version.patch"
+sha512sums="27f5d41730a3070df4ead1af4ec42fdff141289e5072ec93053b9236d9197bc3f1a3a804c85eef08458ab47a0d4921457df57ece5aae42cab9f068ccda31f3ee  libslirp-v4.4.0.tar.gz"
diff --git a/community/libslirp/version.patch b/community/libslirp/version.patch
deleted file mode 100644
index 683aef439a12b9ed93d18c4cbaa1e8064b3dfb93..0000000000000000000000000000000000000000
--- a/community/libslirp/version.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff --git a/meson.build b/meson.build
-index 2e48fd8..5c1f87f 100644
---- a/meson.build
-+++ b/meson.build
-@@ -1,5 +1,5 @@
- project('libslirp', 'c',
--  version : run_command('build-aux/git-version-gen', '@0@/.tarball-version'.format(meson.source_root()), check : true).stdout().strip(),
-+  version : '%SLIRP_VERSION%',
-   license : 'BSD-3-Clause',
-   default_options : ['warning_level=1', 'c_std=gnu99'],
-   meson_version : '>= 0.49',