diff --git a/testing/ptex/APKBUILD b/testing/ptex/APKBUILD
index 73b2c348967c8c70d423edddd96d7294c98124b8..dbca79a94cdc209b18bf949867a822ed9aecc382 100644
--- a/testing/ptex/APKBUILD
+++ b/testing/ptex/APKBUILD
@@ -1,11 +1,11 @@
-# Contributor: Leon Marz <lmarz@cs.uni-frankfurt.de>
-# Maintainer: Leon Marz <lmarz@cs.uni-frankfurt.de>
+# Contributor: Leon Marz <main@lmarz.org>
+# Maintainer: Leon Marz <main@lmarz.org>
 pkgname=ptex
-pkgver=2.3.2
+pkgver=2.4.0
 pkgrel=0
 pkgdesc="texture mapping system by Walt Disney Animation Studios"
 url="https://ptex.us"
-arch="all !s390x !mips !mips64" # tests fail on s390x
+arch="all !s390x !mips64" # ptex doesn't like big endian
 license="BSD-3-Clause"
 makedepends="cmake doxygen graphviz zlib-dev"
 subpackages="$pkgname-static $pkgname-dev $pkgname-doc"
@@ -17,8 +17,7 @@ build() {
 		-DCMAKE_INSTALL_LIBDIR=lib \
 		-DBUILD_SHARED_LIBS=True \
 		-DCMAKE_BUILD_TYPE=None \
-		-DPTEX_VER=$pkgver \
-		.
+		-DPTEX_VER=$pkgver
 	cmake --build build
 }
 
@@ -28,7 +27,9 @@ check() {
 }
 
 package() {
-	DESTDIR="$pkgdir" cmake --build build --target install
+	DESTDIR="$pkgdir" cmake --install build
 }
 
-sha512sums="dbc557dc5e1761204ee3483af9bf4ff1504cbd7955e0405dc27a51f7182e2445e41db086b2792c2491aa2cbaddc74e523170a4b3d25e44d332123d5b7081f4b9  ptex-2.3.2.tar.gz"
+sha512sums="
+02879a7d8c57206d23ba6cacc460e681a4fc03e8939a42ac47e67dcfe0c2fbba247453ea1b6d6a4b8cef389a0830906b018afff6ec8691d01b28ac23fc748c5b  ptex-2.4.0.tar.gz
+"