diff --git a/community/polkit/APKBUILD b/community/polkit/APKBUILD
index a97e222be232c16ebe9dba9f49b93217fa4bcd33..3724aa82545c76cf8c3de2ca96fc0d433fd3282e 100644
--- a/community/polkit/APKBUILD
+++ b/community/polkit/APKBUILD
@@ -3,7 +3,7 @@
 # Contributor: Jakub Jirutka <jakub@jirutka.cz>
 # Maintainer: Natanael Copa <ncopa@alpinelinux.org>
 pkgname=polkit
-pkgver=125
+pkgver=126
 pkgrel=0
 pkgdesc="Application development toolkit for controlling system-wide privileges"
 url="https://github.com/polkit-org/polkit"
@@ -37,7 +37,6 @@ subpackages="
 source="https://github.com/polkit-org/polkit/archive/refs/tags/$pkgver/polkit-$pkgver.tar.gz
 	alpine-polkit.pam
 	polkit.initd
-	args.patch
 	"
 
 # secfixes:
@@ -194,8 +193,7 @@ openrc() {
 }
 
 sha512sums="
-64d85c1557355d6de6483beeb855b74a99dbb30cf9968206dc0aaf147156072ca2604bf667533099ee3972b3eed0421ec0a1ff8bea35a1e4c54da7b9688e0953  polkit-125.tar.gz
+dbdbc31b7a231c963788b37cf1a138e30336466fb662225a812faaf58e45439925d9d39346cc8f07e54f22040c2f142435acb9fded315d33e24930e0abc736c7  polkit-126.tar.gz
 f5102dc00d390b3a3c957b62e1712db778c7ffb7378f3d8e816c0757c11a308c5d5303e42595b0d6add9839247c773880cd34e56afacc89eb6efaadf9aae7826  alpine-polkit.pam
 f6e5ac0ed41feb392dfd104979ec577c5936f3db2bd252b12b7b9b2609a0901dae38bebec1ea65ccf4f427860b520383ae4d2c66fb74ab986c715f6b0ad50473  polkit.initd
-0605c528e25ea1f281ea7708e0185df971174e809ef112c24caa18658b78c6b819890897a4e5d5353098c52be2fccea6a902049c846b3b6b713cb7501f431703  args.patch
 "
diff --git a/community/polkit/args.patch b/community/polkit/args.patch
deleted file mode 100644
index 9038afe3e3c5c56d3aaab8d5a47a86922155e5c8..0000000000000000000000000000000000000000
--- a/community/polkit/args.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-Add missing arguments
-
-Ref https://github.com/polkit-org/polkit/commit/64f5e4dda5240702ea3ad5d00ba8c5207fbacf72
-
---- a/src/polkitbackend/polkitbackendduktapeauthority.c
-+++ b/src/polkitbackend/polkitbackendduktapeauthority.c
-@@ -767,12 +767,14 @@ runaway_killer_common(PolkitBackendJsAuthority *authority, RunawayKillerCtx *ctx
- #ifdef HAVE_PTHREAD_CONDATTR_SETCLOCK
-   if ((pthread_err = pthread_condattr_init(&attr))) {
-     polkit_backend_authority_log (POLKIT_BACKEND_AUTHORITY (authority),
-+                                  LOG_LEVEL_ERROR,
-                                   "Error initializing condition variable attributes: %s",
-                                   strerror(pthread_err));
-     return FALSE;
-   }
-   if ((pthread_err = pthread_condattr_setclock(&attr, PK_CLOCK))) {
-     polkit_backend_authority_log (POLKIT_BACKEND_AUTHORITY (authority),
-+                                  LOG_LEVEL_ERROR,
-                                   "Error setting condition variable attributes: %s",
-                                   strerror(pthread_err));
-     goto err_clean_condattr;
-@@ -780,6 +782,7 @@ runaway_killer_common(PolkitBackendJsAuthority *authority, RunawayKillerCtx *ctx
-   /* Init again, with needed attr */
-   if ((pthread_err = pthread_cond_init(&ctx->cond, &attr))) {
-     polkit_backend_authority_log (POLKIT_BACKEND_AUTHORITY (authority),
-+                                  LOG_LEVEL_ERROR,
-                                   "Error initializing condition variable: %s",
-                                   strerror(pthread_err));
-     goto err_clean_condattr;