From 99e54544a54abb0cb1352e47bbed20a122f76f8d Mon Sep 17 00:00:00 2001
From: Marian Buschsieweke <marian.buschsieweke@posteo.net>
Date: Wed, 4 Dec 2024 02:13:28 +0100
Subject: [PATCH] community/py3-cbor2: upgrade to 5.6.5

https://github.com/agronholm/cbor2/releases/tag/5.6.5
---
 .../py3-cbor2/0001-fix-tests-on-32bit.patch   | 17 +++++++++++
 community/py3-cbor2/APKBUILD                  | 10 +++----
 community/py3-cbor2/fix-32bit-tests.patch     | 29 -------------------
 3 files changed, 22 insertions(+), 34 deletions(-)
 create mode 100644 community/py3-cbor2/0001-fix-tests-on-32bit.patch
 delete mode 100644 community/py3-cbor2/fix-32bit-tests.patch

diff --git a/community/py3-cbor2/0001-fix-tests-on-32bit.patch b/community/py3-cbor2/0001-fix-tests-on-32bit.patch
new file mode 100644
index 000000000000..1b2dbd8abcf6
--- /dev/null
+++ b/community/py3-cbor2/0001-fix-tests-on-32bit.patch
@@ -0,0 +1,17 @@
+diff -rupN a/tests/test_decoder.py b/tests/test_decoder.py
+--- a/tests/test_decoder.py	2024-12-04 02:09:45.093099392 +0100
++++ b/tests/test_decoder.py	2024-12-04 02:11:21.889038455 +0100
+@@ -492,12 +492,7 @@ def test_datetime_date_out_of_range(impl
+     with pytest.raises(impl.CBORDecodeError) as excinfo:
+         impl.loads(unhexlify("a6c11b00002401001b000000000000ff00"))
+ 
+-    if sys.maxsize == 2147483647:
+-        cause_exc_class = OverflowError
+-    elif platform.system() == "Windows":
+-        cause_exc_class = OSError
+-    else:
+-        cause_exc_class = ValueError
++    cause_exc_class = ValueError
+ 
+     assert isinstance(excinfo.value.__cause__, cause_exc_class)
+ 
diff --git a/community/py3-cbor2/APKBUILD b/community/py3-cbor2/APKBUILD
index 2a860d90f99e..13c14da27858 100644
--- a/community/py3-cbor2/APKBUILD
+++ b/community/py3-cbor2/APKBUILD
@@ -1,8 +1,8 @@
 # Contributor: Marian Buschsieweke <marian.buschsieweke@posteo.net>
 # Maintainer: Marian Buschsieweke <marian.buschsieweke@posteo.net>
 pkgname=py3-cbor2
-pkgver=5.6.1
-pkgrel=1
+pkgver=5.6.5
+pkgrel=0
 pkgdesc="encoding and decoding for CBOR (RFC 8949)"
 url="https://github.com/agronholm/cbor2"
 arch="all"
@@ -22,7 +22,7 @@ checkdepends="
 	"
 subpackages="$pkgname-pyc"
 source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/c/cbor2/cbor2-$pkgver.tar.gz
-	fix-32bit-tests.patch
+	0001-fix-tests-on-32bit.patch
 	"
 builddir="$srcdir/cbor2-$pkgver"
 
@@ -44,6 +44,6 @@ package() {
 }
 
 sha512sums="
-9ddf2c3690780816ff50ff4ed371435ca45b597b706254c37c9f01d1f1a699892e2c945a72e69b5506a803c41692f399b58b4e32d9409a0197c677e537e656b2  py3-cbor2-5.6.1.tar.gz
-ba8a19a73fe2dc747846b77fde6cd621ccb500a514ba61192dfa28c875720003666165ad12c767260b31148b0dd25454e36e4f43dd8bb1d11928944c6a5b61dd  fix-32bit-tests.patch
+9c3fc14b579e8c687b3e955452fcf9056fcfcce8ebe72b89c7d6e74e0ba5a29e0a61a225bbb6040f73285dfcc9f3bb37758badbbf45bd723ead8ecdf7e64b685  py3-cbor2-5.6.5.tar.gz
+c550ac530d07d5e190bf7ddb23adafac85398e86429249f9cd0fceb33263de6ac12d5fb4149e7cd2d37d5c4d9178e07dd09a80e4c8609817e545eedb4e1d18d5  0001-fix-tests-on-32bit.patch
 "
diff --git a/community/py3-cbor2/fix-32bit-tests.patch b/community/py3-cbor2/fix-32bit-tests.patch
deleted file mode 100644
index de8fdbb0823f..000000000000
--- a/community/py3-cbor2/fix-32bit-tests.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-Patch-Source: https://github.com/agronholm/cbor2/commit/75279162a019d20db3bff8d64d41c7e97b555b53
-From 75279162a019d20db3bff8d64d41c7e97b555b53 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Alex=20Gr=C3=B6nholm?= <alex.gronholm@nextday.fi>
-Date: Tue, 6 Feb 2024 15:43:23 +0200
-Subject: [PATCH] Fixed test_oversized_read failing on 32-bit platforms
-
-Fixes #215.
----
- tests/test_decoder.py | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/tests/test_decoder.py b/tests/test_decoder.py
-index cd0b45a..d11be6e 100644
---- a/tests/test_decoder.py
-+++ b/tests/test_decoder.py
-@@ -939,11 +939,11 @@ def test_decimal_payload_unpacking(impl, data, expected):
-     "payload",
-     [
-         pytest.param(
--            unhexlify("5b7fffffffffffff00"),
-+            unhexlify("41"),
-             id="bytestring",
-         ),
-         pytest.param(
--            unhexlify("7b7fffffffffffff00"),
-+            unhexlify("61"),
-             id="unicode",
-         ),
-     ],
-- 
GitLab