Commit 99bb40f2 authored by Ivan Tham's avatar Ivan Tham Committed by Leonardo Arena

community/yarn: upgrade to 0.22

parent f2db2fc0
# Contributor: Ed Robinson <ed@reevoo.com>
# Maintainer: Ed Robinson <ed@reevoo.com>
pkgname=yarn
pkgver=0.21.3
pkgver=0.22.0
pkgrel=0
pkgdesc="Fast, reliable, and secure dependency management for Node.js"
url="https://yarnpkg.com/"
arch="noarch"
license="BSD-2"
depends="nodejs"
options="!check"
source="https://yarnpkg.com/downloads/$pkgver/$pkgname-v$pkgver.tar.gz
add-apk-install-method.patch
apk-install-method.patch
remove-support-for-legacy-nodejs.patch"
builddir="$srcdir/dist"
......@@ -52,12 +53,6 @@ package() {
ln -s /$destdir/bin/yarn "$pkgdir"/usr/bin/yarnpkg
}
md5sums="779e0c868fbc2c8235d20755890202fc yarn-v0.21.3.tar.gz
4b137b30af07e34dcb42cbc578bd9350 add-apk-install-method.patch
3f3440fa9a2f50df2ee083f5269e31e5 remove-support-for-legacy-nodejs.patch"
sha256sums="0946a4d1abc106c131b700cc31e5c3aa5f2205eb3bb9d17411f8115354a97d5d yarn-v0.21.3.tar.gz
f94643fa30fd7f02e23f0bd0d73de644940d0bf6df21299fc5fc5f0941377bbd add-apk-install-method.patch
084958810b3f7a81bf6c6a9d7edae563722f8006134d28e82494892a795680d9 remove-support-for-legacy-nodejs.patch"
sha512sums="dad7181c78dd1aaf2b07ff32055a8442b55ff9b68a73cf611f4142d612e95f43dcd376e6f2306a4cccc5249680bb82365a7e9ee3160e5c5083f50ee0791a448d yarn-v0.21.3.tar.gz
4cc2c400f492a5ec7824e0ffd3c11857fdf1488ff21ffd61ad9b6d3135468f32e35cc9b34c496bc0fb07a939bfd635922ca0f574a46c42d117adc1ebf0e6ced4 add-apk-install-method.patch
d62bb07f1361039018ed0a3a3fbff5958c51430e21c356b265768eb494fc74c3c6977e4fdd4629d4914f9afd17864b4a13c8fcda9c92ba9c630badd2f9cea7ad remove-support-for-legacy-nodejs.patch"
sha512sums="56fbadf0dcd077bde75e8e3103c07a3c6d5129b9d8a3ae3b46f8e0f6b149c5e339f435af315b6c52f8415fdaadb60ae8d6be63f8c0f24409145aed21611e1d41 yarn-v0.22.0.tar.gz
30431f7aa5fe7382e062b92e413ea8d118e157d89aa043353c18ff7d1721d0e3ecfbe68de1f0058b3b70cee5cf9baa08d28f1718beb5d14fcb0cf2881dff1eac apk-install-method.patch
b1d0f8e4bee9fb73002f7dbe7cdc5cafdb5bac53e4649bd9d98dbce9afb7950bafd392a4b8433d76aa90f931c2f92972b8ae41fe61f506690439d5959b6c09d5 remove-support-for-legacy-nodejs.patch"
diff -urp dist/package.json patched/package.json
--- dist/package.json 2017-02-01 01:23:37.000000000 +0000
+++ patched/package.json 2017-02-01 01:23:50.000000000 +0000
@@ -1,6 +1,6 @@
{
"name": "yarn",
- "installationMethod": "tar",
+ "installationMethod": "apk",
"version": "0.21.3",
"license": "BSD-2-Clause",
"preferGlobal": true,
--- dist/package.json
+++ dist/package.json
@@ -3 +3 @@
- "installationMethod": "tar",
+ "installationMethod": "apk",
diff -urp dist/bin/yarn.js patched/bin/yarn.js
--- dist/bin/yarn.js 2017-01-30 14:11:29.000000000 +0000
+++ patched/bin/yarn.js 2017-02-01 02:41:32.000000000 +0000
@@ -16,17 +16,14 @@ var _err;
--- dist/bin/yarn.js
+++ dist/bin/yarn.js
@@ -13,10 +13,8 @@
if (semver.satisfies(ver, '>=5.0.0')) {
possibles.push('../updates/current/lib/cli/index.js');
possibles.push('../lib/cli/index.js');
path = '../lib/cli/index.js';
-} else if (semver.satisfies(ver, '>=4.0.0')) {
- possibles.push('../updates/current/lib-legacy/cli/index.js');
- possibles.push('../lib-legacy/cli/index.js');
- path = '../lib-legacy/cli/index.js';
} else {
- console.log(require('chalk').red('Node version ' + ver + ' is not supported, please use Node.js 4.0 or higher.'));
+ console.log(require('chalk').red('Node version ' + ver + ' is not supported, please use Node.js 5.0 or higher.'));
process.exit(1);
}
@@ -27,7 +25,7 @@
// ensure cache directory exists
var mkdirp = require('mkdirp');
-var constants = require('../lib-legacy/constants');
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment