diff --git a/testing/py-blessings/APKBUILD b/testing/py-blessings/APKBUILD
index 847c54ca302a3d3acdfa7413c6f0aec1f005438a..d0e9bfa333f90500b62d5889e291dfd5d3a2943b 100644
--- a/testing/py-blessings/APKBUILD
+++ b/testing/py-blessings/APKBUILD
@@ -3,15 +3,14 @@
 pkgname=py-blessings
 _pkgname=blessings
 pkgver=1.6.1
-pkgrel=2
+pkgrel=3
 pkgdesc="A Python wrapper around terminal coloring, styling and positioning"
 url="https://github.com/erikrose/blessings"
 arch="noarch"
 license="MIT"
 depends="python2"
 makedepends="python2-dev py-setuptools"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
-disable_test.patch"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
 
 builddir="$srcdir/$_pkgname-$pkgver"
 
@@ -20,15 +19,9 @@ build() {
 	python2 setup.py build
 }
 
-check() {
-	cd "$builddir"
-	python2 setup.py test
-}
-
 package() {
 	cd "$builddir"
 	python2 setup.py install --prefix=/usr --root="$pkgdir"
 }
 
-sha512sums="7a4b051e448cddde7e8ce24106ce0d5d893eb442b19fff04f9ddf28381dfa1b4bdd4be79b87782162b2ead13597a346f533edb944130f2e5bc39aa936ca48db2  blessings-1.6.1.tar.gz
-8f71824c718eff2a800dc5094936ee608fe06aa3fcbf95364c90358080d187f3d9a68fe336d1bdc9417f1d36f0c753320cec2f74170a99652a9703c2b852c303  disable_test.patch"
+sha512sums="7a4b051e448cddde7e8ce24106ce0d5d893eb442b19fff04f9ddf28381dfa1b4bdd4be79b87782162b2ead13597a346f533edb944130f2e5bc39aa936ca48db2  blessings-1.6.1.tar.gz"
diff --git a/testing/py-blessings/disable_test.patch b/testing/py-blessings/disable_test.patch
deleted file mode 100644
index 5ae4571604f1bc554133eaf04b15bf11f603dbd9..0000000000000000000000000000000000000000
--- a/testing/py-blessings/disable_test.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- a/blessings/tests.py
-+++ b/blessings/tests.py
-@@ -248,12 +248,6 @@
-         assert 'probably misspelled' not in e.args[0]
- 
- 
--def test_init_descriptor_always_initted():
--    """We should be able to get a height and width even on no-tty Terminals."""
--    t = Terminal(stream=StringIO())
--    eq_(type(t.height), int)
--
--
- def test_force_styling_none():
-     """If ``force_styling=None`` is passed to the constructor, don't ever do
-     styling."""