diff --git a/testing/py3-discogs-client/APKBUILD b/testing/py3-discogs-client/APKBUILD
index 12eba84453dc5ad56a934b929629d5c8f6f5e5d0..5ce338cf092ea435592c2bca80c079c360343f02 100644
--- a/testing/py3-discogs-client/APKBUILD
+++ b/testing/py3-discogs-client/APKBUILD
@@ -1,17 +1,16 @@
 # Contributor: Carlo Landmeter <clandmeter@gmail.com>
-# Maintainer:
+# Maintainer: Justin Berthault <justin.berthault@zaclys.net>
 pkgname=py3-discogs-client
-_pkgname=discogs-client
-pkgver=2.2.2
-pkgrel=3
+pkgver=2.3.0
+pkgrel=0
 pkgdesc="Official Python API client for Discogs"
 url="https://github.com/discogs/discogs_client"
 arch="noarch"
 license="BSD-2-Clause"
 depends="py3-oauthlib py3-requests py3-six"
 makedepends="py3-setuptools"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-builddir="$srcdir"/$_pkgname-$pkgver
+source="https://files.pythonhosted.org/packages/source/d/discogs-client/discogs-client-$pkgver.tar.gz"
+builddir="$srcdir"/discogs-client-$pkgver
 
 replaces="py-discogs-client" # for backwards compatibility
 provides="py-discogs-client=$pkgver-r$pkgrel" # for backwards compatibility
@@ -28,4 +27,4 @@ package() {
 	python3 setup.py install --prefix=/usr --root="$pkgdir"
 }
 
-sha512sums="cf08526f739216efa9ef628f28650c8074cd6ddb21e0ab5431a8c8864c1f2707f612b065baf6b2f907b7fa7cdf2cfe5905cbefddb02c6f8f1c7796b0631a2ba7  discogs-client-2.2.2.tar.gz"
+sha512sums="1912c0b9a3ff5ef33bcea92e322580458b78c5ad280cfde1f1e180a096bd2afe8f0d22059b985a8efd6fe5a84b54fecbeee521ccc698c694b3d6d3e66f976afc  discogs-client-2.3.0.tar.gz"