Commit 94aa630b authored by Francesco Colista's avatar Francesco Colista

community/certbot: upgrade to 0.36.0

Added a patch to make it work with edge py3-setuptools.
Basically it removes the check against the version (since the version on edge is 41.0.0 and the min requirement is 36.2).

On cerbot 0.36.0 there is no longer certbot-postfix, that has been removed upstream.
Changelog does not mention this.
parent 6b66b7df
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=certbot
pkgver=0.35.1
pkgver=0.36.0
pkgrel=0
pkgdesc="An ACME client that can update Apache/Nginx configurations"
url="https://github.com/certbot/certbot"
......@@ -13,6 +13,7 @@ depends="
py3-configargparse
py3-configobj
py3-cryptography
py3-distutils-extra
py3-josepy
py3-mock
py3-parsedatetime
......@@ -25,8 +26,9 @@ depends="
checkdepends="py3-augeas"
makedepends="python3-dev"
replaces="letsencrypt"
subpackages="py3-acme:acme $pkgname-nginx $pkgname-apache $pkgname-postfix"
source="certbot-$pkgver.tar.gz::https://github.com/certbot/certbot/archive/v$pkgver.tar.gz"
subpackages="py3-acme:acme $pkgname-nginx $pkgname-apache"
source="certbot-$pkgver.tar.gz::https://github.com/certbot/certbot/archive/v$pkgver.tar.gz
remove-check-for-setuptools-version.patch"
build() {
local i
......@@ -96,18 +98,5 @@ apache() {
python3 setup.py install --prefix=/usr --root="$subpkgdir"
}
postfix() {
cd "$builddir"/certbot-apache
pkgdesc="postfix plugin for $pkgname"
depends="
certbot=$pkgver-r$pkgrel
py3-acme=$pkgver-r$pkgrel
py3-setuptools
py3-six
py3-zope-component
py3-zope-interface
"
python3 setup.py install --prefix=/usr --root="$subpkgdir"
}
sha512sums="a4dc2ac2e451f2aaf99c545f8dc8e960783465519be6e29f52e5ee53dd49175f86df5613829fa801d8aa56ddfc9b79e27dba33eda89f3d0a0fae52ef881b0afa certbot-0.35.1.tar.gz"
sha512sums="f7fa8c6200a76b4fc4830865bf11fbba8bd73ea55e1236680181073952505c83b4650b43ccfc8e9b96caf47b85c43e47acf8db6d92134f7c279ebd954ab0ac92 certbot-0.36.0.tar.gz
cc9647c9d1d6909e3d3df7adcb5816f814c4665ec54a5d0680b4a97d1599451db0fd192ff2e3a91c174ec2d8681fe0f62d7a3d40cc07081d058a6a6169f734a3 remove-check-for-setuptools-version.patch"
diff --git a/setup.py b/setup.py
index 84c27fc..97b0606 100644
--- a/setup.py
+++ b/setup.py
@@ -58,11 +58,11 @@ install_requires = [
# However environment markers are supported only with setuptools >= 36.2.
# So this dependency is not added for old Linux distributions with old setuptools,
# in order to allow these systems to build certbot from sources.
-if StrictVersion(setuptools_version) >= StrictVersion('36.2'):
- install_requires.append("pywin32 ; sys_platform == 'win32'")
-elif 'bdist_wheel' in sys.argv[1:]:
- raise RuntimeError('Error, you are trying to build certbot wheels using an old version '
- 'of setuptools. Version 36.2+ of setuptools is required.')
+#if StrictVersion(setuptools_version) >= StrictVersion('36.2'):
+# install_requires.append("pywin32 ; sys_platform == 'win32'")
+#elif 'bdist_wheel' in sys.argv[1:]:
+# raise RuntimeError('Error, you are trying to build certbot wheels using an old version '
+# 'of setuptools. Version 36.2+ of setuptools is required.')
dev_extras = [
'astroid==1.6.5',
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment