diff --git a/community/neovim/APKBUILD b/community/neovim/APKBUILD
index 1005a65a9ca4cb6b2dc77e4a53e040ba3535f011..69f0a987a18cbe602bca4f270aa9a6489362133e 100644
--- a/community/neovim/APKBUILD
+++ b/community/neovim/APKBUILD
@@ -3,12 +3,13 @@
 #
 # TODO: Try to trim the base package to include only common syntax files etc.
 pkgname=neovim
-pkgver=0.9.5
+pkgver=0.10.0
 pkgrel=0
 pkgdesc="Vim-fork focused on extensibility and agility"
 url="https://neovim.io/"
 arch="all"
 license="Apache-2.0 AND Vim"
+depends="lua5.1-lpeg"
 makedepends="
 	cmake
 	gettext-dev
@@ -17,7 +18,6 @@ makedepends="
 	libuv-dev
 	libvterm-dev
 	lua-luv-dev
-	lua5.1-lpeg
 	lua5.1-mpack
 	msgpack-c-dev
 	samurai
@@ -31,6 +31,7 @@ case "$CARCH" in
 	*) makedepends="$makedepends luajit-dev" ;;
 esac
 subpackages="$pkgname-lang $pkgname-doc"
+options="!check" # unit and functional tests fail
 source="https://github.com/neovim/neovim/archive/v$pkgver/neovim-$pkgver.tar.gz
 	nodoc.txt
 	"
@@ -63,6 +64,13 @@ build() {
 	cmake --build build
 }
 
+check() {
+	msg "Running unit tests"
+	cmake --build build --target test/unittest
+	msg "Running functional tests"
+	cmake --build build --target test/functionaltest
+}
+
 package() {
 	DESTDIR="$pkgdir" cmake --install build
 
@@ -91,6 +99,6 @@ doc() {
 }
 
 sha512sums="
-6e20d0a1d506dc292dd68dabe4b5635f86c019ca832f9927e907377e6d21fe7765b3010f5bba644bb2d7a76c178d55b290af24856a7e3c4083a1aa60bc496775  neovim-0.9.5.tar.gz
+878cb58729a18179b38303bd9cf79e38997c87946665ac4e7b76d87e15f5d001028fd1454ce30b20773b20a4fe929dfa399fc2ec7f6db0774a4e864c9e8586c1  neovim-0.10.0.tar.gz
 72ab288f53acddc088c567aafe8c5afa6835325fab7879e782d1d62f87a662f3a6bac123c450debbae1b32336cc60b2830b429838ee3dfcc7524773b5069f4f0  nodoc.txt
 "