diff --git a/testing/harminv/APKBUILD b/testing/harminv/APKBUILD
index ee1c385bb7895b6bbc3e2c84c4ab5e95e536fc3d..cca41dddf554f6fbb37b3fc5fd1625d01fda07d4 100644
--- a/testing/harminv/APKBUILD
+++ b/testing/harminv/APKBUILD
@@ -5,7 +5,7 @@ pkgver=1.4.1
 pkgrel=1
 pkgdesc="Free program to solve the problem of harmonic inversion"
 url="https://github.com/stevengj/harminv"
-arch="all"
+arch="all !s390x"
 license="GPL"
 depends_dev="openblas-dev"
 makedepends="$depends_dev gfortran"
diff --git a/testing/lazperf/APKBUILD b/testing/lazperf/APKBUILD
index a272ce56978a2743d232596dd2c690cb19621cd3..2194a97a08a53c41a2bb47c240c5803b0a5c16de 100644
--- a/testing/lazperf/APKBUILD
+++ b/testing/lazperf/APKBUILD
@@ -5,7 +5,7 @@ pkgver=1.1.0
 pkgrel=0
 pkgdesc="Alternative LAZ implementation for C++ and JavaScript"
 url="https://github.com/hobu/laz-perf"
-arch="all !armhf"  # armhf: io_test segfaults
+arch="all !armhf !s390x"  # armhf: io_test segfaults
 license="LGPL-2.0-or-later"
 makedepends="cmake"
 install=""
diff --git a/testing/nim/APKBUILD b/testing/nim/APKBUILD
index 709ea5eb384a4f42e2bffe7d3fc7d311795db399..a0575cd3e4c60f86a8fe220cda02f1c51ca4f2ba 100644
--- a/testing/nim/APKBUILD
+++ b/testing/nim/APKBUILD
@@ -7,7 +7,7 @@ pkgver=0.17.2
 pkgrel=1
 pkgdesc="A systems and applications programming language"
 url="https://nim-lang.org/"
-arch="all"
+arch="all !s390x"
 license="MIT"
 checkdepends="sqlite-libs nodejs"
 subpackages="$pkgname-doc nimsuggest niminst"
diff --git a/testing/perl-sys-syscall/APKBUILD b/testing/perl-sys-syscall/APKBUILD
index b1db87687edf4ff3098d61554e44a582b86ac96e..f5f405e3cf1743128048bfccac181d305ca8a3f4 100644
--- a/testing/perl-sys-syscall/APKBUILD
+++ b/testing/perl-sys-syscall/APKBUILD
@@ -7,7 +7,7 @@ pkgver=0.25
 pkgrel=1
 pkgdesc="Invoke system calls that are otherwise difficult to do from Perl"
 url="http://search.cpan.org/dist/Sys-Syscall/"
-arch="all !aarch64 !ppc64le"
+arch="all !aarch64 !ppc64le !s390x"
 license="GPL PerlArtistic"
 cpandepends=""
 cpanmakedepends=""
diff --git a/testing/py-cpuinfo/APKBUILD b/testing/py-cpuinfo/APKBUILD
index d06bbe40d3513d2c015659378539e44623d93f13..1e42bb313c2ffad998514fda42f46dff60cf7ae4 100644
--- a/testing/py-cpuinfo/APKBUILD
+++ b/testing/py-cpuinfo/APKBUILD
@@ -6,7 +6,7 @@ pkgver=3.3.0
 pkgrel=0
 pkgdesc="A module for getting CPU info"
 url="https://github.com/workhorsy/py-cpuinfo"
-arch="noarch"
+arch="noarch !s390x"
 license="MIT"
 makedepends="python2-dev py-setuptools python3-dev"
 subpackages="py3-$_pkgname:_py3 py2-$_pkgname:_py2"
diff --git a/testing/py-fonttools/APKBUILD b/testing/py-fonttools/APKBUILD
index d79737eca5142b1a3b1aa11feedcb8c9d17b6726..cf2f034a9a0385c28af81f48a4276f12cf06f17c 100644
--- a/testing/py-fonttools/APKBUILD
+++ b/testing/py-fonttools/APKBUILD
@@ -5,7 +5,7 @@ pkgver=3.21.2
 pkgrel=0
 pkgdesc="Converts OpenType and TrueType fonts to and from XML"
 url="https://github.com/fonttools/fonttools"
-arch="noarch"
+arch="noarch !s390x"
 license="BSD"
 depends="py-numpy"
 makedepends="python2-dev python3-dev py-setuptools"
diff --git a/testing/py-gnuplot/APKBUILD b/testing/py-gnuplot/APKBUILD
index e7a998156ab4510f1e7eb35a3f3ad1a9b52c3bb6..c187c440806393a93302125972c2ab2881be5352 100644
--- a/testing/py-gnuplot/APKBUILD
+++ b/testing/py-gnuplot/APKBUILD
@@ -6,7 +6,7 @@ pkgver=1.8
 pkgrel=0
 pkgdesc="A Python interface to the gnuplot plotting program."
 url="http://gnuplot-py.sourceforge.net"
-arch="noarch"
+arch="noarch !s390x"
 license="LGPL"
 depends="python2 py-numpy gnuplot"
 depends_dev=""
diff --git a/testing/py-matplotlib/APKBUILD b/testing/py-matplotlib/APKBUILD
index 99425bcf32ca309c4fde324a381f7ef9daef4c40..45e057e3f689e2a8d30dbbc6cb84e761f83c5713 100644
--- a/testing/py-matplotlib/APKBUILD
+++ b/testing/py-matplotlib/APKBUILD
@@ -6,7 +6,7 @@ pkgver=1.5.1
 pkgrel=2
 pkgdesc="A Python library for plots"
 url="http://matplotlib.org"
-arch="all"
+arch="all !s390x"
 license="custom"
 depends="python2 py-numpy python2-tkinter py-dateutil py-parsing py-tz py-cycler"
 makedepends="python2-dev gfortran py-numpy-dev freetype-dev libpng-dev tk-dev
diff --git a/testing/py-opengl/APKBUILD b/testing/py-opengl/APKBUILD
index 174aea8816d27d8108269ba105eda5bbab055995..69566737bae59fed7e0844c3c84e63f481eb7535 100644
--- a/testing/py-opengl/APKBUILD
+++ b/testing/py-opengl/APKBUILD
@@ -6,7 +6,7 @@ pkgver=3.1.1a1
 pkgrel=1
 pkgdesc="Standard OpenGL bindings for Python"
 url="http://pyopengl.sourceforge.net"
-arch="noarch"
+arch="noarch !s390x"
 license="BSD"
 depends="python2 freeglut mesa-gles py-pillow py-numpy"
 depends_dev=""
diff --git a/testing/py-scipy/APKBUILD b/testing/py-scipy/APKBUILD
index 3060a33ba34a1225e89c7528250c53ba37052f91..11aa32447107de1fbcc147360836869e7e419353 100644
--- a/testing/py-scipy/APKBUILD
+++ b/testing/py-scipy/APKBUILD
@@ -5,7 +5,7 @@ pkgver=0.19.1
 pkgrel=1
 pkgdesc="Python library for scientific computing"
 url="http://www.scipy.org"
-arch="all"
+arch="all !s390x"
 license="BSD"
 depends="py-numpy-f2py"
 makedepends="python2-dev python3-dev py-setuptools gfortran py-numpy-dev openblas-dev cython-dev"
diff --git a/testing/radare2/APKBUILD b/testing/radare2/APKBUILD
index 4e869da8d1da1a6cfa7f413146e2b8c35cbbd664..d3c94f7200b7c1dbfe2790d8899f425e0a8fe5b9 100644
--- a/testing/radare2/APKBUILD
+++ b/testing/radare2/APKBUILD
@@ -20,6 +20,7 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/radare/$pkgname/archive/${pk
 builddir="$srcdir"/$pkgname-$pkgver
 
 build() {
+	[ "$CARCH" = "s390x" ] && _disable_debugger="--disable-debugger"
 	cd "$builddir"
 	./configure \
 		--build=$CBUILD \
@@ -28,6 +29,7 @@ build() {
 		--sysconfdir=/etc \
 		--mandir=/usr/share/man \
 		--localstatedir=/var \
+		$_disable_debugger \
 		--with-syscapstone \
 		--with-openssl \
 		--with-syszip
diff --git a/testing/tcc/APKBUILD b/testing/tcc/APKBUILD
index c8bde7628e74de05a6d05644ea8571dd8b3f21cf..046df9eb8a4bd474d5532f77db75a8662050dd9d 100644
--- a/testing/tcc/APKBUILD
+++ b/testing/tcc/APKBUILD
@@ -7,7 +7,7 @@ _commit=fc0188ffbcf29f856caedee8cef07d88be01e439
 pkgrel=0
 pkgdesc="Tiny C Compiler"
 url="http://repo.or.cz/tinycc.git"
-arch="all !ppc64le"
+arch="all !ppc64le !s390x"
 license="LGPL-2.1"
 makedepends="texinfo"
 options="!check" # test suite currently fails on the server
diff --git a/testing/texlive/APKBUILD b/testing/texlive/APKBUILD
index cb5f837f3e860c64611f86c18af40735770889ac..b945b737fbf8b36e18d355f1f24f41822ee48c8d 100644
--- a/testing/texlive/APKBUILD
+++ b/testing/texlive/APKBUILD
@@ -26,7 +26,7 @@ _xetex="xelatex xelollipop"
 build() {
 	cd "$builddir"
 
-	if [ "$CARCH" = "ppc64le" ] ; then
+	if [ "$CARCH" = "ppc64le" ] || [ "$CARCH" = "s390x" ] ; then
 		EXTRA="--disable-luajittex --disable-mfluajit"
 	fi
 
diff --git a/testing/thermald/APKBUILD b/testing/thermald/APKBUILD
index f525d2eb510ff315d64e032c6462afcc83bd9550..bd5f12285b4bd3c8f0e6c7c53be73515940cea12 100644
--- a/testing/thermald/APKBUILD
+++ b/testing/thermald/APKBUILD
@@ -6,7 +6,7 @@ pkgver=1.6
 pkgrel=0
 pkgdesc="Thermal daemon for IA"
 url="https://github.com/01org/thermal_daemon"
-arch="all !armhf !aarch64"
+arch="all !armhf !aarch64 !s390x"
 license="GPL-2.0"
 depends=""
 makedepends="autoconf automake libtool dbus-glib-dev libxml2-dev linux-headers"
diff --git a/testing/websockify/APKBUILD b/testing/websockify/APKBUILD
index e65bac5ddc20c6ea9f48941838ba9452968f03c1..5557ecdb58fdc81ca17d8e11761d1ecd9fa0b23a 100644
--- a/testing/websockify/APKBUILD
+++ b/testing/websockify/APKBUILD
@@ -5,7 +5,7 @@ pkgver=0.8.0
 pkgrel=1
 pkgdesc="WebSockets support for any application/server"
 url="https://github.com/kanaka/websockify"
-arch="noarch"
+arch="noarch !s390x"
 license="LGPL-3.0"
 depends="py2-$pkgname=$pkgver-r$pkgrel py-setuptools py2-numpy"
 makedepends="python2-dev"