From 92632169a7bb23b3b55b6a7b51ce760af37cad30 Mon Sep 17 00:00:00 2001
From: psykose <alice@ayaya.dev>
Date: Fri, 4 Feb 2022 10:37:58 +0000
Subject: [PATCH] testing/amule: fix build with gcc11

---
 testing/amule/APKBUILD                |  9 +++++++--
 testing/amule/fix-gcc11-include.patch | 10 ++++++++++
 2 files changed, 17 insertions(+), 2 deletions(-)
 create mode 100644 testing/amule/fix-gcc11-include.patch

diff --git a/testing/amule/APKBUILD b/testing/amule/APKBUILD
index 8c1fabc37000..54e63bd9f1da 100644
--- a/testing/amule/APKBUILD
+++ b/testing/amule/APKBUILD
@@ -12,7 +12,9 @@ makedepends="bison boost-dev crypto++-dev gd-dev geoip-dev libsm-dev libupnp-dev
 	wxgtk3-dev"
 options="!check" # unexpected end of file
 subpackages="$pkgname-lang $pkgname-doc"
-source="$_pkgname-$pkgver.tar.xz::https://downloads.sourceforge.net/project/amule/aMule/2.3.3/aMule-$pkgver.tar.xz"
+source="$_pkgname-$pkgver.tar.xz::https://downloads.sourceforge.net/project/amule/aMule/2.3.3/aMule-$pkgver.tar.xz
+	fix-gcc11-include.patch
+	"
 
 builddir="$srcdir/$_pkgname-$pkgver"
 
@@ -49,4 +51,7 @@ package() {
 	make DESTDIR="$pkgdir" install
 }
 
-sha512sums="a5a80c5ddd1e107d92070c1d8e232c2762c4c54791abc067c739eef7c690062ed164dd7733808f80c762719261162aeb3d602308964dda2670a0bb059d87b74e  aMule-2.3.3.tar.xz"
+sha512sums="
+a5a80c5ddd1e107d92070c1d8e232c2762c4c54791abc067c739eef7c690062ed164dd7733808f80c762719261162aeb3d602308964dda2670a0bb059d87b74e  aMule-2.3.3.tar.xz
+ce5e35ad33a188358dc311df06a2357dba52b5905f345dcba0fb44337ee1a1314579e918cb4e0cc60818a39d5c4678321262e9d6b1e17fe800fda55a5def1976  fix-gcc11-include.patch
+"
diff --git a/testing/amule/fix-gcc11-include.patch b/testing/amule/fix-gcc11-include.patch
new file mode 100644
index 000000000000..34fb3367e341
--- /dev/null
+++ b/testing/amule/fix-gcc11-include.patch
@@ -0,0 +1,10 @@
+--- a/src/libs/common/MuleDebug.cpp
++++ b/src/libs/common/MuleDebug.cpp
+@@ -24,6 +24,7 @@
+ //
+ 
+ #include <cstdlib>			// Needed for std::abort()
++#include <exception>
+ 
+ #include "config.h"			// Needed for HAVE_CXXABI and HAVE_EXECINFO
+ 
-- 
GitLab