diff --git a/testing/viddy/APKBUILD b/testing/viddy/APKBUILD
new file mode 100644
index 0000000000000000000000000000000000000000..6990f2c63b5f39f6f164196c2f36a6eb56ac72ed
--- /dev/null
+++ b/testing/viddy/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Marvin Preuss <marvin@xsteadfastx.org>
+# Maintainer: Marvin Preuss <marvin@xsteadfastx.org>
+pkgname=viddy
+pkgver=0.1.5
+pkgrel=0
+pkgdesc="Modern watch command. Time machine and pager etc."
+url="https://github.com/sachaos/viddy"
+arch="all"
+license="MIT"
+makedepends="go"
+source="$pkgname-$pkgver.tar.gz::https://github.com/sachaos/viddy/archive/refs/tags/v$pkgver.tar.gz"
+
+export GOFLAGS="$GOFLAGS -modcacherw"
+
+build() {
+	go build -ldflags "-X main.version=$pkgver"
+}
+
+check() {
+	go test ./...
+}
+
+package() {
+	install -Dm755 $pkgname "$pkgdir"/usr/bin/"$pkgname"
+}
+sha512sums="
+60e5966ad5c8435c110a309a53e406c7fe4b74d1162c84209c63d878f5aed0d0e31733eed71b43d95227c29e4ae1de41386f82252304106538667f8209fc75df  viddy-0.1.5.tar.gz
+"