Commit 9146177d authored by Leonardo Arena's avatar Leonardo Arena
Browse files

community/nextcloud: upgrade to 16.0.0

parent ac7a3163
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
pkgname=nextcloud
pkgver=15.0.7
pkgver=16.0.0
pkgrel=0
pkgdesc="A safe home for all your data"
url="http://nextcloud.com"
......@@ -27,7 +27,7 @@ subpackages="$pkgname-doc $pkgname-initscript $pkgname-mysql $pkgname-pgsql $pkg
$pkgname-default-apps:_default_apps"
source="https://download.nextcloud.com/server/releases/$pkgname-$pkgver.zip
nextcloud15-dont-chmod.patch
nextcloud15-app-encryption-info-add-mcrypt.patch
nextcloud16-app-encryption-info-add-mcrypt.patch
dont-update-htaccess.patch
disable-integrity-check-as-default.patch
iconv-ascii-translit-not-supported.patch
......@@ -228,9 +228,9 @@ _package_app() {
mv "$pkgdir"/$_appsdir/$appname "$subpkgdir"/$_appsdir/
}
sha512sums="8d44a85554cc07c9ff97916eb76adacd415f7241e094c1e68b2e2e657f926ccb14831dee01bd01c1f74db534325a7123b1505d32a8fd4c88de0a8bb6dc63a2a8 nextcloud-15.0.7.zip
sha512sums="3e867c420bb1d7ea751d454205b6fc2d84bfa378a27748971acca8a60b0fe4a3dd0edca8b535c6a20d4343ba20808b9e0d76ce736e6a45bd12229c61a423f28c nextcloud-16.0.0.zip
59151300c1153cad7fa2a1a972825c81a71df523b319b22799ce1bd846c1a63c7e37c608a125a98e4e733857cc65db9f329fafef7a5b1365d802c476450fce22 nextcloud15-dont-chmod.patch
e9d15d00368c8840c0144a9f0f45a951717b6c441f98a98568c064639f223df4b6190be040fc56840d3a23b3f7c69348b3d9e94ad4e86f371754ecd057a329d2 nextcloud15-app-encryption-info-add-mcrypt.patch
ebc7fdfb9f4d4256186f80ae3a2aa92cb4c7c54db3c185b642a37cd9ecbbb9ad557a1beea143018b987fbfa47667812ca09e68b304d04cc21f308a690e658275 nextcloud16-app-encryption-info-add-mcrypt.patch
aef3c92497d738d6968e0f0b0d415b4953500db24ae14af41ef972665cf7eff00cb6c53dc953845fdbb389c3c965a75b8b14b9247513c05cf4130fe1cfc61731 dont-update-htaccess.patch
d2100a837fef1eeae5f706650ab4c985d9e00f61efa5526ef76c7c1f5811c3906eb6c3c13c151eff9677a0c303faab64411a5a84d6792728bc520d2c618d7d5b disable-integrity-check-as-default.patch
de1b433c2fb2582b599cb25e718e454fc4b93543a5a60eee39a03bcccf35d281594611395bdebe02319bedd9a894507eef97010ebdfca381e0f1a09df283d375 iconv-ascii-translit-not-supported.patch
......
mcrypt is not required, but it's recommended to increase file encryption
performance. We're adding it to info.xml just to simplify abuild (all app
dependencies can be read in info.xml).
diff --git a/apps/encryption/appinfo/info.xml b/apps/encryption/appinfo/info.xml
index db4309c..4c43c09 100644
index 5050996..6df2d2b 100644
--- a/apps/encryption/appinfo/info.xml
+++ b/apps/encryption/appinfo/info.xml
@@ -31,6 +31,7 @@
......@@ -11,6 +7,6 @@ index db4309c..4c43c09 100644
<dependencies>
<lib>openssl</lib>
+ <lib>mcrypt</lib>
<nextcloud min-version="15" max-version="15" />
<nextcloud min-version="16" max-version="16"/>
</dependencies>
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment