diff --git a/main/beep/APKBUILD b/main/beep/APKBUILD
index aa0195eeea102bbbcdaf528e8bf094d1959e854d..c539c0e4c51afe62052c594ccdcf1262ff156b74 100644
--- a/main/beep/APKBUILD
+++ b/main/beep/APKBUILD
@@ -1,34 +1,27 @@
 # Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
 # Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
 pkgname=beep
-pkgver=1.3
-pkgrel=2
+pkgver=1.4.4
+pkgrel=0
 pkgdesc="A terminal bell"
-url="http://johnath.com/beep"
+url="https://github.com/spkr-beep/beep"
 arch="all"
 license="GPL-2.0"
-depends=""
 makedepends="linux-headers"
-install=""
 subpackages="$pkgname-doc"
-source="http://johnath.com/$pkgname/$pkgname-$pkgver.tar.gz"
-
-_builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
-	cd "$_builddir"
-}
+source="$pkgname-$pkgver.tar.gz::https://github.com/spkr-beep/beep/archive/v$pkgver.tar.gz
+	fix-gzip-man.patch"
+builddir="$srcdir"/$pkgname-$pkgver
 
 build() {
-	cd "$_builddir"
-	make || return 1
+	cd "$builddir"
+	make
 }
 
 package() {
-	cd "$_builddir"
-	install -m755 -D "$srcdir/$pkgname-$pkgver/beep" "$pkgdir"/usr/bin/beep
-	install -m644 -D "$srcdir/$pkgname-$pkgver/beep.1.gz" "$pkgdir"/usr/share/man/man1/beep.1.gz
+	cd "$builddir"
+	make DESTDIR="$pkgdir" install
 }
 
-md5sums="49c340ceb95dbda3f97b2daafac7892a  beep-1.3.tar.gz"
-sha256sums="59acef7a987de5557cefd1a904666cc2691f132929af39e65450b182a581ec2d  beep-1.3.tar.gz"
-sha512sums="3f71146202208fa0c0cda360d125dd972ea003cf8cd62da21d67eb544c92f7b82640e7ce7c3835cbc65c75909a882edfa54dbd8d8b748d6f243711ea331477fd  beep-1.3.tar.gz"
+sha512sums="cfaecbebbbd0596bee5f304c3bd74968d06873037d054def0907dfd36e5bd6e7fbd7d7051eacedd20480b88f8b4e343db05eb5d3dde0fdced33756545b630373  beep-1.4.4.tar.gz
+b0828a0ee0050ca9f601b824f95af78a4db556e1f7b94d8d2a9927a939629fcddf03151c283ed3552c03fb750e06c6880781dcf31926869b66a4793bc6b381fc  fix-gzip-man.patch"
diff --git a/main/beep/fix-gzip-man.patch b/main/beep/fix-gzip-man.patch
new file mode 100644
index 0000000000000000000000000000000000000000..89eff2a593419cfd05ef3c5094be3f7f2109f8b7
--- /dev/null
+++ b/main/beep/fix-gzip-man.patch
@@ -0,0 +1,11 @@
+--- a/GNUmakefile	2019-04-02 19:49:59.000000000 +0200
++++ b/GNUmakefile	2019-09-21 14:08:33.043968397 +0200
+@@ -215,7 +215,7 @@
+ 	mv -f $@.tmp $@
+ 
+ %.1.gz: %.1
+-	$(GZIP) --best -c < $< > $@
++	$(GZIP) -c < $< > $@
+ 
+ HTML_DATA += html/README.html
+ HTML_DATA += html/INSTALL.html