From 90686ddd97f5832100dec1eb662d71e7c67cd5f2 Mon Sep 17 00:00:00 2001
From: Andy Postnikov <apostnikov@gmail.com>
Date: Tue, 21 May 2024 20:33:06 +0200
Subject: [PATCH] community/php82: upgrade to 8.2.20 and use clang18

---
 community/php82/APKBUILD            | 16 +++++++++------
 community/php82/curl880.patch       | 32 +++++++++++++++++++++++++++++
 community/php82/disabled-tests.list |  3 ---
 3 files changed, 42 insertions(+), 9 deletions(-)
 create mode 100644 community/php82/curl880.patch

diff --git a/community/php82/APKBUILD b/community/php82/APKBUILD
index a734c4c98fb8..0674984fb39e 100644
--- a/community/php82/APKBUILD
+++ b/community/php82/APKBUILD
@@ -26,7 +26,7 @@
 
 pkgname=php82
 _pkgreal=php
-pkgver=8.2.19
+pkgver=8.2.20
 pkgrel=0
 _apiver=20220829
 _suffix=${pkgname#php}
@@ -48,15 +48,17 @@ _depends_phar="$pkgname"
 # openssl is actually transitive dependency here, but we need to because of
 # load index based on number of dependencies.
 _depends_mysqli="$pkgname-mysqlnd $pkgname-openssl"
+_clang_ver=18
 makedepends="
 	$depends_dev
 	acl-dev
+	apache2
 	apache2-dev
 	argon2-dev
 	aspell-dev
 	bison
 	bzip2-dev
-	clang
+	clang$_clang_ver
 	curl-dev
 	enchant2-dev
 	freetds-dev
@@ -115,6 +117,7 @@ source="php-$pkgver.tar.xz::https://php.net/distributions/$_pkgreal-$pkgver.tar.
 	phpinfo-avif.patch
 	fix-icu74.patch
 	loongarch64-support-for-fibers.patch
+	curl880.patch
 	"
 builddir="$srcdir/$_pkgreal-$pkgver"
 
@@ -252,8 +255,8 @@ _build() {
 		export CXXFLAGS="${CXXFLAGS/-fstack-clash-protection}"
 		;;
 	esac
-	export CC=clang
-	export CXX=clang++
+	export CC=clang-$_clang_ver
+	export CXX=clang++-$_clang_ver
 	EXTENSION_DIR=$_extension_dir ./configure \
 		--build=$CBUILD \
 		--host=$CHOST \
@@ -633,11 +636,11 @@ _extensions_by_load_order() {
 }
 
 sha512sums="
-5ba7ab4317f7880a6cea93bf6d3a48d62db6bfcb5682be7e13a6a6f7bd1fef96ca813c2cf95f6b5020756f03b298995d1722367adb2580c1db221a2f9e311038  php-8.2.19.tar.xz
+c659ed4809b6507aa428b483c85c7322815ac9d7d8e4bfe575513a5e69c5a680b8d089fd98a19f83d3a00df3de61468809f21408455913aa24d519776e44abc5  php-8.2.20.tar.xz
 f8662f7f5fcf286ba138d735538b62c0611df7941f3b398e6d2128077555f0ce133b6428f2607d3102c2e7323f2c58a4501727493584383a863e2f4e83057e7a  php82-fpm.initd
 29dc69d06c25ecc194b617e9af7c42fbdbe634a8312a5c6a1ab8e2d582cb64ed2f53308eeaa45dcf71b7f5618e6ef3e9d8a9d6932685e0d8af86203f43481bd9  php82-fpm.logrotate
 504f0e4aca2dfd36f428006fe6442557e99f8608f683467ae95519b5219208951bf3ba7223af69728a4e055110f5e491ea4b484db2f696410ce35f4999a8481a  php82-module.conf
-9e407b4fff13dad933974374ff237d9cb3c778e0780a43a7c12ce04153d47e37fb823d62cf84362c427ce586d200e721555235945faf91f2343028d2caa4216c  disabled-tests.list
+35051488c4f09bae4c3b4747571a759209e99590297c9e95ab04e9d593ae4e4d7a83ffc4c639c397d8a6a58296a77a43b4cb2ec5b5a25c3bacf2eb5ef316951b  disabled-tests.list
 4818e0247d8efa2f58a38c563e7bcb9a5d3cd1e668d489d341dfc293230c4608a5587200f9bdfe73fdd854443a30a5a862ff4975aefda7b77ed09871d1148ee1  disabled-tests.x86.list
 30cba10c11f800d23e013c7f92cadb7e2a9ac5e89e5466445c77761369e7f3b8daba7ae64e23967329139b01f37f187acd2f1f1e3dfb0bca2e900a7d7e1afd07  disabled-tests.ppc64le.list
 54930246f22034e6a73020aa95915d14b2a2fcfe121df57eb17fdc663aceeb94c5c4b1800347149a8fb4eaa0edda4224a11133bdb7e0cd34a2065a2de121db0d  disabled-tests.s390x.list
@@ -650,4 +653,5 @@ f93c6544fe7cc630b72c2315b312e327b39d7a46e9bcd0d00d37d92863dd44c06f96f74539f0ef93
 8833c5c6f5225f5e85a9cd842274e4e6b2f55dc572a13bdb3066c624f82c9f39fa07cb2f8f242092ff814f61f0cb8abaa792b1f93c16ad341f1a8dec05a6ca2d  phpinfo-avif.patch
 b376af772b4b92ce50f955a9becff47784383b4d453419d8c06ae4e712ccaabeea4898ca6a6ab6c3bbf1fdcc720ccf3fa85a8c0e538c914ea667ab58d0ba396c  fix-icu74.patch
 517441fdf14b7855b1843bd0d1c86126017af7a340fbf7177202db7c9e67912332abdb62e7477f45e7922c910672396ba4f953eb7dc052ed06624c682bd12791  loongarch64-support-for-fibers.patch
+c3a2356fb88d54f354518f6eff50646e4c39bfdf825bcd3456948346286dc17d0c50d4be71ce70f726d7f493209ad85cf7a5e4d94b77177306bd6ef0a14d4ac8  curl880.patch
 "
diff --git a/community/php82/curl880.patch b/community/php82/curl880.patch
new file mode 100644
index 000000000000..dd80f0e1087e
--- /dev/null
+++ b/community/php82/curl880.patch
@@ -0,0 +1,32 @@
+Patch-Source: https://github.com/php/php-src/commit/a2c5b4ec05da0c26370332988b30befa43e29e77
+From a2c5b4ec05da0c26370332988b30befa43e29e77 Mon Sep 17 00:00:00 2001
+From: Niels Dossche <7771979+nielsdos@users.noreply.github.com>
+Date: Thu, 23 May 2024 22:20:37 +0200
+Subject: [PATCH] Fix GH-14307: Test curl_basic_024 fails with curl 8.8.0
+
+Curl changed the behaviour, from the changelog:
+  - lib: make protocol handlers store scheme name lowercase curl/curl@c294f9c
+
+From the docs: "The returned scheme might be upper or lowercase. Do
+comparisons case insensitively."
+
+Closes GH-14312.
+---
+ NEWS                               | 3 +++
+ ext/curl/tests/curl_basic_024.phpt | 4 ++--
+ 2 files changed, 5 insertions(+), 2 deletions(-)
+
+diff --git a/ext/curl/tests/curl_basic_024.phpt b/ext/curl/tests/curl_basic_024.phpt
+index b16bfed03835f..84216bde308eb 100644
+--- a/ext/curl/tests/curl_basic_024.phpt
++++ b/ext/curl/tests/curl_basic_024.phpt
+@@ -25,7 +25,7 @@ var_dump(0 === curl_getinfo($ch, CURLINFO_PROXY_SSL_VERIFYRESULT));
+ var_dump(curl_getinfo($ch, CURLINFO_SCHEME));
+ curl_close($ch);
+ ?>
+---EXPECT--
++--EXPECTF--
+ bool(true)
+ bool(true)
+-string(4) "HTTP"
++string(4) "%r(HTTP|http)%r"
diff --git a/community/php82/disabled-tests.list b/community/php82/disabled-tests.list
index 6289a6afa5fc..9f75be84ba8f 100644
--- a/community/php82/disabled-tests.list
+++ b/community/php82/disabled-tests.list
@@ -144,9 +144,6 @@ ext/iconv/tests/iconv_mime_encode.phpt
 # Requires running SNMP server.
 ext/snmp/tests/*
 
-# Expects permissions on /etc to be 40755 (armhf)
-ext/standard/tests/file/006_error.phpt
-
 # Fails on riscv64 CI (lmdb and socket_set_option)
 ext/dba/tests/bug78808.phpt
 ext/dba/tests/dba_lmdb.phpt
-- 
GitLab