diff --git a/community/uacme/APKBUILD b/community/uacme/APKBUILD
index e6dfe5ae8514cf41e46e16bddc920634f34c1d38..f8f2800eb998cd4b1e74e6acc6827128534b9c30 100644
--- a/community/uacme/APKBUILD
+++ b/community/uacme/APKBUILD
@@ -2,7 +2,7 @@
 # Maintainer: Eivind Uggedal <eu@eju.no>
 pkgname=uacme
 pkgver=1.3
-pkgrel=1
+pkgrel=2
 pkgdesc="Lightweight client for the RFC8555 ACMEv2 protocol"
 url="https://github.com/ndilieto/uacme"
 arch="all"
@@ -10,7 +10,7 @@ license="GPL-3.0-or-later ISC MIT"
 makedepends="openssl-dev curl-dev asciidoc"
 subpackages="$pkgname-doc"
 options="!check"  # no test suite
-source="uacme-$pkgver.tar.gz::https://github.com/ndilieto/uacme/archive/v$pkgver.tar.gz"
+source="uacme-upstream-$pkgver.tar.gz::https://github.com/ndilieto/uacme/archive/upstream/$pkgver.tar.gz"
 builddir="$srcdir/uacme-upstream-$pkgver"
 
 build() {
@@ -32,4 +32,4 @@ package() {
 	install -d "$pkgdir"/var/www/.well-known/acme-challenge
 }
 
-sha512sums="0abc89bec514fc6c816b331851e4df49fde16d8d6b04f14320921cfeae6e6a7b81a0654a4213edbf0329a0f6264b209269df7cb9daf1f222c6cf935b6d1ce1e2  uacme-1.3.tar.gz"
+sha512sums="a8e78f28a906fe511c2c61db47773cf73245d50e354a42f95931954f33d071a4a89262c1ed7da7cd1c8ed33ba66297585950ed73cb7cd6dba860e4280a7d964d  uacme-upstream-1.3.tar.gz"