diff --git a/community/gotosocial/APKBUILD b/community/gotosocial/APKBUILD
index 0bf90c523e7a75c4b33541594579382129cada75..9157e32c994b8c963085fe071779a2e16f60be33 100644
--- a/community/gotosocial/APKBUILD
+++ b/community/gotosocial/APKBUILD
@@ -2,7 +2,7 @@
 # Maintainer: Alex McGrath <amk@amk.ie>
 pkgname=gotosocial
 pkgver=0.17.3
-pkgrel=1
+pkgrel=2
 pkgdesc="An ActivityPub social network server"
 url="https://github.com/superseriousbusiness/gotosocial"
 arch="all"
@@ -41,7 +41,7 @@ prepare() {
 }
 
 build() {
-	yarn --cwd ./web/source install
+	yarn --cwd ./web/source install --frozen-lockfile
 	yarn --cwd ./web/source ts-patch install
 	yarn --cwd ./web/source build
 	go build -o gotosocial -ldflags="-X 'main.Version=$_pkgver'" -tags nowasm \