From 89dfd9aa1a78f83fc0713d6193b8ad4cc60b2e02 Mon Sep 17 00:00:00 2001
From: Dennis Krupenik <dennis@krupenik.com>
Date: Fri, 13 Nov 2020 21:05:10 +0200
Subject: [PATCH] testing/intel-graphics-compiler: upgrade to 1.0.5435

---
 testing/intel-graphics-compiler/APKBUILD                 | 6 +++---
 .../intel-graphics-compiler/remove-rtld-deepbind.patch   | 9 +++++----
 2 files changed, 8 insertions(+), 7 deletions(-)

diff --git a/testing/intel-graphics-compiler/APKBUILD b/testing/intel-graphics-compiler/APKBUILD
index 6ed7faabd05d..65bcbaa39a8c 100644
--- a/testing/intel-graphics-compiler/APKBUILD
+++ b/testing/intel-graphics-compiler/APKBUILD
@@ -1,7 +1,7 @@
 # Contributor: Dennis Krupenik <dennis@krupenik.com>
 # Maintainer: Dennis Krupenik <dennis@krupenik.com>
 pkgname=intel-graphics-compiler
-pkgver=1.0.5353
+pkgver=1.0.5435
 pkgrel=0
 pkgdesc="Intel® Graphics Compiler for OpenCL™"
 url="https://github.com/intel/intel-graphics-compiler"
@@ -44,7 +44,7 @@ package() {
 	make -C build DESTDIR="$pkgdir" install
 }
 
-sha512sums="e9f20e2261c5cb79d365d5d8257e8f4830b2364962c48413cc80154469db34c1c844ae5d576cbce2e3c5e5cbe22c7c3710ebd0a7fe7208e5412e81ce20077c80  igc-1.0.5353.tar.gz
+sha512sums="539aca07509d2bfb5f43fc15c0f8c4af5b500d7bd1c867952c50212d54c5b64f03b985d4d787e32ffa75e8ccb89390c169b5404033537ce3c1fcc36d472ac60f  igc-1.0.5435.tar.gz
 8f27fd371fd760734c37f650b3816dfd9cfbe5caea0c70a2805d22ae9dc1370ae91005a2fad09c7ae5564fc795099602eb9faab59f2f4e3cc18a5a3be8eb5507  eabcd2022cf868a658b257b8ea6ad62acbbe7dc5.zip
 da8430649519f5f55e09175bacbb817321dfca9403dd49c93a14cbfd55b512a7d4da6659cd63a02787345104dbcad001cc5fea7c4c3a23f30539c1dbcce2f4b0  portable-compiler-concat.patch
-d88d2f8f2500b519d6b92a7ac7ed8d725f579ade818b6b44836772effb4ed4e6c2c06175021e87391d21adf802ef60dbf9a78f0178195b9307bfe6ddea21c76d  remove-rtld-deepbind.patch"
+dd91fcfad005d4db01dbda61a4954ecc3ab9b734e3434f9c62c252b5ed64eced85c7af051cb00b8085cdfd8a04b537052467a4c9239ed6a13911666ed8f886f8  remove-rtld-deepbind.patch"
diff --git a/testing/intel-graphics-compiler/remove-rtld-deepbind.patch b/testing/intel-graphics-compiler/remove-rtld-deepbind.patch
index bf3824bb3502..074a79d7ace0 100644
--- a/testing/intel-graphics-compiler/remove-rtld-deepbind.patch
+++ b/testing/intel-graphics-compiler/remove-rtld-deepbind.patch
@@ -2,12 +2,13 @@ RTLD_DEEPBIND is a glibc thing
 ---
 --- a/IGC/VectorCompiler/lib/GenXCodeGen/GenXWrapper.cpp
 +++ b/IGC/VectorCompiler/lib/GenXCodeGen/GenXWrapper.cpp
-@@ -101,7 +101,7 @@
- 
+@@ -123,8 +123,7 @@
+   const std::string SpirvLibPath = findSpirvDLL();
  #if defined(__linux__)
    // Hack to workaround cmoc crashes during loading of SPIRV library
--  static auto DeepBindHack = dlopen(SpirvLibName, RTLD_NOW | RTLD_DEEPBIND);
-+  static auto DeepBindHack = dlopen(SpirvLibName, RTLD_NOW);
+-  static auto DeepBindHack =
+-      dlopen(SpirvLibPath.c_str(), RTLD_NOW | RTLD_DEEPBIND);
++  static auto DeepBindHack = dlopen(SpirvLibPath.c_str(), RTLD_NOW);
  #endif // __linux__
  
    using DL = sys::DynamicLibrary;
-- 
GitLab