From 893bda38cc1836f4cecff47e6c78d41d01b44e6b Mon Sep 17 00:00:00 2001
From: psykose <alice@ayaya.dev>
Date: Thu, 15 Jun 2023 00:04:29 +0000
Subject: [PATCH] community/dotnet6-build: mask fstack-clash-protection outside
 of x86

---
 community/dotnet6-build/APKBUILD | 14 ++++++++++----
 1 file changed, 10 insertions(+), 4 deletions(-)

diff --git a/community/dotnet6-build/APKBUILD b/community/dotnet6-build/APKBUILD
index dfe1875f239d..719590af823d 100644
--- a/community/dotnet6-build/APKBUILD
+++ b/community/dotnet6-build/APKBUILD
@@ -306,13 +306,19 @@ build() {
 	done
 	local args="$args /p:TargetRid=$ID.$VERSION_ID-$_dotnet_arch"
 
+	case "$CARCH" in
+	x86*) ;;
+	*)
+		# clang doesn't implement this outside of x86, and it causes a later configure to fail
+		export CFLAGS="${CFLAGS/-fstack-clash-protection}"
+		export CXXFLAGS="${CXXFLAGS/-fstack-clash-protection}"
+		;;
+	esac
+
 	./build.sh \
 		--with-sdk "$_cli_root" \
 		--with-packages "$_artifactsdir" \
-		-- $args || {
-		find . -name "CMakeConfigureLog.yaml" -type f -exec sh -c 'echo logfile: $1; cat $1' - {} \;
-		return 1
-	}
+		-- $args
 }
 
 check() {
-- 
GitLab