diff --git a/community/dotnet6-build/APKBUILD b/community/dotnet6-build/APKBUILD
index dfe1875f239d8ac6154ab3f6a496574072534a03..719590af823da784184b13b247ba712e565893aa 100644
--- a/community/dotnet6-build/APKBUILD
+++ b/community/dotnet6-build/APKBUILD
@@ -306,13 +306,19 @@ build() {
 	done
 	local args="$args /p:TargetRid=$ID.$VERSION_ID-$_dotnet_arch"
 
+	case "$CARCH" in
+	x86*) ;;
+	*)
+		# clang doesn't implement this outside of x86, and it causes a later configure to fail
+		export CFLAGS="${CFLAGS/-fstack-clash-protection}"
+		export CXXFLAGS="${CXXFLAGS/-fstack-clash-protection}"
+		;;
+	esac
+
 	./build.sh \
 		--with-sdk "$_cli_root" \
 		--with-packages "$_artifactsdir" \
-		-- $args || {
-		find . -name "CMakeConfigureLog.yaml" -type f -exec sh -c 'echo logfile: $1; cat $1' - {} \;
-		return 1
-	}
+		-- $args
 }
 
 check() {