From 885fd221a6ac899d5134004df8bc41042533381c Mon Sep 17 00:00:00 2001
From: psykose <alice@ayaya.dev>
Date: Thu, 19 Jan 2023 01:25:46 +0000
Subject: [PATCH] community/ocaml: run tests in parallel

this s much faster, to put it mildly
---
 community/ocaml/APKBUILD | 7 +++----
 1 file changed, 3 insertions(+), 4 deletions(-)

diff --git a/community/ocaml/APKBUILD b/community/ocaml/APKBUILD
index f68009794238..9488872a2944 100644
--- a/community/ocaml/APKBUILD
+++ b/community/ocaml/APKBUILD
@@ -3,13 +3,14 @@
 # Maintainer: omni <omni+alpine@hack.org>
 pkgname=ocaml
 pkgver=4.14.1
-pkgrel=0
+pkgrel=1
 pkgdesc="Main implementation of the Caml programming language"
 url="https://ocaml.org/"
 arch="all !riscv64" # hangs forever at final build step
 license="LGPL-2.1-or-later-WITH-linking-exception"
 depends="$pkgname-runtime=$pkgver-r$pkgrel gcc"
 makedepends="gdbm-dev libc-dev ncurses-dev zlib-dev binutils-dev"
+checkdepends="parallel"
 subpackages="
 	$pkgname-doc
 	$pkgname-dev
@@ -40,9 +41,7 @@ build() {
 }
 
 check() {
-	make ocamlopt
-	make ocamltest
-	make tests
+	make -C testsuite parallel
 }
 
 package() {
-- 
GitLab